Opened 6 years ago

Closed 5 years ago

#17751 closed enhancement (wontfix)

use native placeholder support for form inputs

Reported by: liucougar Owned by: liucougar
Priority: undecided Milestone: tbd
Component: Dijit - Form Version: 1.9.3
Keywords: Cc:
Blocked By: Blocking:

Description

if browser natively supports placeholder in input (and alike), use the native support instead

Attachments (3)

17751.patch (3.1 KB) - added by liucougar 6 years ago.
updated patch
17751.2.patch (3.1 KB) - added by liucougar 6 years ago.
updated patch
17751.3.patch (19.1 KB) - added by liucougar 6 years ago.
updated patch with test fixes

Download all attachments as: .zip

Change History (16)

comment:1 Changed 6 years ago by liucougar

Component: GeneralDijit - Form

comment:2 Changed 6 years ago by bill

I figured we'd drop the custom placeholder code for 2.0, when all our supported platforms have native placeholder support... except IE9, that would have "graceful degradation". Is there a reason to branch the behavior (in 1.x)?

Last edited 6 years ago by bill (previous) (diff)

comment:3 Changed 6 years ago by liucougar

we are seeing some problems with the custom placeholder when it's used in auto-complete input in a dialog: even if they are filled by browser autocomplete, the custom placeholder still show up

i could not find a way to fix the custom placeholder implementation

comment:4 Changed 6 years ago by bill

Owner: set to liucougar
Status: newpending

OK, fair enough.

The tests need to be updated though; IE8 is getting failures in ValidationTextBox?, ComboBox? and FilteringSelect? (the last two are actually from the same test file). I'm confused why that happens since IE8 doesn't have native placeholder support.

Thanks.

Last edited 6 years ago by bill (previous) (diff)

Changed 6 years ago by liucougar

Attachment: 17751.patch added

updated patch

comment:5 Changed 6 years ago by liucougar

Status: pendingnew

Attachment (17751.patch) added by ticket reporter.

Changed 6 years ago by liucougar

Attachment: 17751.2.patch added

updated patch

comment:6 Changed 6 years ago by liucougar

i believe the error is caused by bidi support (I forgot to include a change in the original patch)

could you try the updated patch? I believe it will work fine in IE8. thanks

comment:7 Changed 6 years ago by bill

Status: newpending

It still fails. The failing tests are not BIDI tests, they are plain LTR tests.

Changed 6 years ago by liucougar

Attachment: 17751.3.patch added

updated patch with test fixes

comment:8 Changed 6 years ago by liucougar

Status: pendingnew

Attachment (17751.3.patch) added by ticket reporter.

comment:9 Changed 6 years ago by liucougar

the attached patch fixes a bug in the original patch, and it also modifies tests so they won't fail when placeholder is natively supported

comment:10 Changed 6 years ago by Heng Liu <liucougar@…>

Resolution: fixed
Status: newclosed

In 63486c0569d7ba60e351cf01f36dd8f007ed3b48/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:11 Changed 6 years ago by Colin Snover <github.com@…>

In 6e60fb4aa317146fa86f44ee36a725131e5470ba/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:12 Changed 6 years ago by Colin Snover

Resolution: fixed
Status: closedreopened

As per Dojo meeting discussion, 63486c05 was reverted due to its impact on backcompat. The issue with autocomplete not allowing placeholders to be hidden should be opened and tracked in a different defect ticket.

comment:13 Changed 5 years ago by bill

Resolution: wontfix
Status: reopenedclosed
Note: See TracTickets for help on using tickets.