Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#17745 closed defect (fixed)

pressing ENTER doesn't move caret to next line, caret sometimes disappears (IE10)

Reported by: bill Owned by: Bill Keese <bill@…>
Priority: undecided Milestone: 1.8.7
Component: Editor Version: 1.9.2
Keywords: Cc:
Blocked By: Blocking:

Description

To reproduce:

  1. Load test_Editor.html on IE10.
  2. Position caret at end of text in "editor1" (the second editor on the page).
  3. Use ENTER key to input some new lines of text

First bug: pressing ENTER does not move the caret to the next line; it only moves when you start typing printable characters (ex: hello world).

Next, click into editor2, then back to editor1, and repeat the experiment. This shows the second bug, where the caret disappears completely (until you start typing some characters).

Caused by the EnterKeyHandling? plugin. Maybe related to #13744.

Change History (6)

comment:1 Changed 6 years ago by Bill Keese <bill@…>

Owner: set to Bill Keese <bill@…>
Resolution: fixed
Status: newclosed

In f569ab4d48ab9a225f12eae3bdf423abcd25e84f/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:2 Changed 6 years ago by Bill Keese <bill@…>

In 7adf55b21a7938dce7d369dacf87c423d7423be7/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:3 Changed 6 years ago by bill

Milestone: tbd1.9.3

comment:4 Changed 5 years ago by bill

PS: Actually _stripTrailingEmptyNodes() only removes the final &nbsp;. There mayb be others interspersed throughout the doc; not sure.

comment:5 Changed 5 years ago by Bill Keese <bill@…>

In d991ff0ad244eef0e2a6cc83545b06f48041ddba/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:6 Changed 5 years ago by bill

Milestone: 1.9.31.8.7
Note: See TracTickets for help on using tickets.