Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#17744 closed defect (fixed)

[regression] _HasDropDown: dropdown misaligned when right-aligned and autoWidth:true

Reported by: bill Owned by: Bill Keese <bill@…>
Priority: undecided Milestone: 1.9.3
Component: Dijit Version: 1.9.2
Keywords: Cc:
Blocked By: Blocking:

Description

Starting from 4d1ddb9 (see #10631), if a dropdown is right-aligned (anchor node right border flush with dropdown right border), and then its width is increased due to autoWidth: true setting, the positioning will be off. It's because the width is increased without the style.left value being adjusted.

Happens mainly on RTL pages.

See attached test file.

Attachments (1)

DojoTest.html (2.2 KB) - added by bill 5 years ago.
test file

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by bill

Attachment: DojoTest.html added

test file

comment:1 Changed 5 years ago by Bill Keese <bill@…>

Owner: set to Bill Keese <bill@…>
Resolution: fixed
Status: newclosed

In 0984b1ee62a6659b3f9013a34f16357cf8cabb99/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:2 Changed 5 years ago by Bill Keese <bill@…>

In 8aa577651c284adae6a5606fbfb332b5aacfec28/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:3 Changed 5 years ago by bill

Milestone: tbd1.9.3

comment:4 Changed 5 years ago by bill

#17671 is a duplicate of this ticket.

Note: See TracTickets for help on using tickets.