Opened 6 years ago

Closed 6 years ago

#17737 closed defect (duplicate)

dijit.form.Select has an invalid WAI-ARIA property.

Reported by: shanshuo Owned by:
Priority: undecided Milestone: tbd
Component: Dijit - Form Version: 1.7.2
Keywords: Cc: Becky Gibson
Blocked By: Blocking:

Description (last modified by bill)

I use dijit.form.Select like:

<label for="${id}_linesLimitField">Line limit:</label>
	<select id="${id}_linesLimitField" data-dojo-attach-point="myOptions" data-dojo-type="dijit.form.Select" style="width:55px;">
		<option value=10>10</option>
		<option value=100>100</option>
		<option value=500>500</option>
		<option value=1000>1000</option>
		<option value=2000 selected="selected">2000</option>
	</select>

And met the following error descriptions(for JAWS screen reader accessibility):"An element having a role must reference valid global or widget WAI-ARIA properties."

I found that the dijit.layout.Select widget's outermost table node has role="combobox", and has a property aria-valuetext="2000".

According to WAI-ARIA specification, aria-valuetext is not a WAI-ARIA global property nor a widget WAI-ARIA property, and it should not be contained in the element that has role="combobox".

Change History (3)

comment:1 Changed 6 years ago by bill

Cc: Becky Gibson added
Description: modified (diff)

Thanks. The aria-valuetext setting is from 37ef4c067de4c13937de02a5fdfd597f4a481cde, refs #10927. Becky do you have a suggestion for another attribute to use?

I looked at http://www.w3.org/TR/wai-aria/roles#combobox, and IIUC it says you are supposed to indicate the current value via aria-activedescendant, which references another node, like aria-labelledby. So not a trivial fix.

I also checked how dijit/form/ComboBox works, but it sends focus to an <input value=2000>. So, Select is a different ball of wax because it doesn't have an <input>.

comment:2 Changed 6 years ago by Becky Gibson

This seems to be fixed in the current nightly (http://archive.dojotoolkit.org/nightly/dojotoolkit/dijit/tests/form/test_Select.html as of Feb. 17, 2013) as using firebug I see the role as listbox and no aria-valuetext attribute when looking at Test one. Do you have to provide a fix for the 1.7.2 version listed on the ticket?

comment:3 Changed 6 years ago by bill

Resolution: duplicate
Status: newclosed

Duplicate of #15466.
Ah right, it was fixed for 1.8.

Note: See TracTickets for help on using tickets.