Opened 5 years ago

Closed 5 years ago

#17735 closed defect (duplicate)

TitlePane must be labeled with aria-label or aria-labelledby

Reported by: shanshuo Owned by: bill
Priority: undecided Milestone: 1.10
Component: Dijit Version: 1.7.2
Keywords: Cc:
Blocked By: Blocking:

Description

I use dijit.TitlePane? in a normal way. And met the following error descriptions(for JAWS screen reader accessibility): 1)"Elements containing a 'region' role must be labeled with an aria-label or aria-labelledby." 2)"Elements having a WAI-ARIA group role must have a label specified with aria-label or aria-labelledby except when there is parent element containing a menu, menubar, or tree role".

I found that for issue 1), it's due to the containerNode in TitlePane? has a role='region' but misses aria-label or aria-labelledby. for issue 2), that's due to TitlePane? outermost node has role='group' but misses aria-label or aria-labelledby. Acoording to WAI-ARIA specification, TitlePane? widget should do so.

Change History (3)

comment:1 Changed 5 years ago by bill

Milestone: tbd1.10
Owner: set to bill
Status: newassigned

Makes sense, sounds like both the root node and the containerNode should have an aria-labelledby pointing to the titleNode.

comment:2 Changed 5 years ago by bill

Actually, the containerNode already has an aria-labelledby, added in #15853.

comment:3 Changed 5 years ago by bill

Resolution: duplicate
Status: assignedclosed

Duplicate of #15853.
And actually, the role=group is gone from the root node starting in version 1.8. So AFAICT there's no issue here, but rather you are just looking at an old dojo version.

Note: See TracTickets for help on using tickets.