Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#17726 closed defect (wontfix)

ScrollableView laggy/unresponsive on Galaxy S3 stock browser

Reported by: Neon Owned by: Adrian Vasiliu
Priority: undecided Milestone: tbd
Component: DojoX Mobile Version: 1.9.2
Keywords: Cc:
Blocked By: Blocking:

Description

Scrolling on an S3 is generally unresponsive and laggy.

This appears to only happen on the default browser for the Samsung Galaxy S3 (Android 4.3), it's not reproducible on other browsers.

This is reproducible by attempting to scroll on this page on a Galaxy S3's default browser. http://jsbin.com/lured/6/

Change History (4)

comment:1 Changed 6 years ago by Adrian Vasiliu

Owner: set to Adrian Vasiliu
Status: newassigned

comment:2 Changed 6 years ago by Adrian Vasiliu

This appears to be due to a bug of the stock browser introduced by the Android 4.3 upgrade of Galaxy S3. Indeed, it goes this way:

  • Reproduced with stock browser on Galaxy S3 GT-I9300 Android 4.3 (while not reproduced with Chrome on the same device).
  • I do NOT reproduce with stock browser on Galaxy S3 GT-I9300 Android 4.1.2.
  • I do NOT reproduce with stock browser on other Android phones, such as HTC One X Android 4.2.2.
  • I have verified that this is not a side-effect of the changes done for #17454: the issue is also present with Dojo 1.9.0 for instance.
  • The issue holds for any of the 3 modes (scrollType) of ScrollableView?.
  • The Android 4.3 update of S3 is known as having been a painful one. Samsung pushed a first version, then pushed it back (see for instance http://www.androidauthority.com/galaxy-s3-android-4-3-jelly-bean-update-performance-battery-issues-hold-316828/) because of numerous issues, among them performance issues. Some of these issues have then been solved, but obviously not all...

All in one, I don't see what we can do about it on Dojo's side. Hopefully the issue will go away in the next Android update for S3.

See also http://livedocs.dojotoolkit.org/dojox/mobile/faq#why-scrolling-is-fast-and-smooth-on-some-devices-browsers-but-not-on-all.

comment:3 Changed 6 years ago by Adrian Vasiliu

Resolution: wontfix
Status: assignedclosed
Summary: ScrollableView laggy/unresponsive on Galaxy S3ScrollableView laggy/unresponsive on Galaxy S3 stock browser

comment:4 Changed 6 years ago by Adrian Vasiliu

Moreover, the issue appears to be a bug of the Android 4.3 stock browser on the S3 only - I do not reproduce it with the Android 4.3 stock browser on S4 GT-I9505.

Note: See TracTickets for help on using tickets.