Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#17680 closed enhancement (fixed)

make this.own() handle Promises

Reported by: iDo Owned by: bill
Priority: undecided Milestone: 1.10
Component: Dijit Version: 1.9.2
Keywords: Cc:
Blocked By: Blocking:

Description

It would be handy to add "cancel" in the list of functions own() can handle. Thanks to that we could use own() to cancel very long (and still running) XHR/Deferred when a widget gets destroyed.

See https://github.com/dojo/dijit/pull/17 for changes

Change History (8)

comment:1 Changed 6 years ago by iDo

Forgot to mention [CLA] in the title :/

comment:2 Changed 6 years ago by dylan

Summary: add "cancel" handling to Destroyable[patch][cla] add "cancel" handling to Destroyable

comment:3 Changed 6 years ago by bill

Milestone: tbd1.10
Owner: set to bill
Status: newassigned

Looks good, thanks, I'll check it in.

comment:4 Changed 6 years ago by Bill Keese <bill@…>

Resolution: fixed
Status: assignedclosed

In 797f9a9d5e08aa0e208691e7086a679c8c630e30/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:5 Changed 6 years ago by bill

#17863 is a duplicate of this ticket.

comment:6 Changed 6 years ago by bill

Summary: [patch][cla] add "cancel" handling to Destroyablemake this.own() handle Promises

comment:7 Changed 6 years ago by Bill Keese <bill@…>

In 9234eeeffcd957152dd4c0307d76aeff76ec933a/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:8 Changed 6 years ago by Bill Keese <bill@…>

In e5dcf8ee33dadc4a84a4432497dc407d8549f65b/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 
Note: See TracTickets for help on using tickets.