Opened 6 years ago

Closed 5 years ago

#17665 closed defect (wontfix)

Rounded/Arced dojox/mobile/Switches do not render correctly on Samsung S4 browser

Reported by: Patrick Ruzand Owned by: Patrick Ruzand
Priority: undecided Milestone: tbd
Component: DojoX Mobile Version: 1.9.2
Keywords: Cc:
Blocked By: Blocking:

Description

A dojox/mobile/Switch configured with a round or arc shape is not rendered correctly on the Samsung S4 default browser in Android 4.2 (note: it's ok with Chrome for Android).

To reproduce: 1.run the dojox/mobile/tests/test_Switch.html 2.=> all the switches are squared, whatever the specified shape is.

Attachments (3)

test_border-radius.html (931 bytes) - added by Patrick Ruzand 6 years ago.
a pure html testcase showing the limitation
test_border-radius.2.html (1.0 KB) - added by Patrick Ruzand 6 years ago.
add -webkit- test.
Screenshot_2014-01-10-16-23-22.png (64.9 KB) - added by Patrick Ruzand 6 years ago.
screenshot

Download all attachments as: .zip

Change History (6)

comment:1 Changed 6 years ago by Patrick Ruzand

Owner: set to Patrick Ruzand
Status: newassigned

The issue is due to the fact that the Samsung default browser does not support the border-radius CSS3 property (seems a regression in the webkit build they used, since it's ok on an HTC One/4.2 whose default browser has an older webkit version, according to its UA string). The workaround is to use the specific border-top-left-radius/border-top-right-radius/etc. forms that are supported... I attached a simple pure html testcase that demonstrates this.

Changed 6 years ago by Patrick Ruzand

Attachment: test_border-radius.html added

a pure html testcase showing the limitation

comment:2 Changed 6 years ago by Patrick Ruzand

Corresponding Pull Request: https://github.com/dojo/dojox/pull/62

Changed 6 years ago by Patrick Ruzand

Attachment: test_border-radius.2.html added

add -webkit- test.

Changed 6 years ago by Patrick Ruzand

screenshot

comment:3 Changed 5 years ago by Patrick Ruzand

Resolution: wontfix
Status: assignedclosed

see https://github.com/dojo/dojox/pull/62 for possible fix/workaround. Won't fix the lib, as it a S4 bug and does not happen on S4 4.3 update.

Note: See TracTickets for help on using tickets.