Opened 5 years ago

Closed 5 years ago

#17655 closed defect (invalid)

tooltip on stacked bar chart is causing series to show on mouse over action when series are hidden by legend

Reported by: czhang Owned by: czhang
Priority: undecided Milestone: tbd
Component: Charting Version: 1.9.2
Keywords: Cc:
Blocked By: Blocking:

Description

create a chart with ""dojox/charting/Chart"; add a plot: chart.addPlot("Stacked", {type:StackedBars}); add axis, and theme, series; add tooltip action: new Tooltip(chart, "Stacked"); render the chart: chart.render(); add selectable legend: new SelectableLegend?({ chart: chart }, "legend");

start the page; once the chart is rendered, hide all series using legend; do mouseover on the chart, you will see series shows in black color.

Change History (4)

comment:1 Changed 5 years ago by czhang

one more issue: use legend to hide the series, and then show them; now you have highlighting effect when mouseover the series.

comment:2 Changed 5 years ago by cjolif

Owner: set to cjolif
Status: newassigned

SelectableLegend has been improved in master would you be willing give it a try and see if your problem is solved? If not it will accelerate investigation if you provide directly a sample instead of just the steps.

comment:3 Changed 5 years ago by cjolif

Owner: changed from cjolif to czhang
Status: assignedpending

This is working fine with test_selectableLegend.html in trunk. So I would need definitely need a sample reproducing the issue.

comment:4 Changed 5 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.