Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#17626 closed defect (fixed)

[regression] With Dojo 1.9.2, pages are jumping to the bottom after onload in Chrome

Reported by: Cormac Flynn Owned by: Colin Snover
Priority: blocker Milestone: 1.9.3
Component: Events Version: 1.9.2
Keywords: Cc:
Blocked By: Blocking:

Description

Hey,

I have a strange issue that has arisen since updating to Dojo 1.9.2; upon page load, the page is jumping to the bottom.

This happens consistently and only with Dojo 1.9.2 on Chrome - if I downgrade to 1.9.1 it never happens, and I don't see it at all on Firefox.

I've commented out all Dojo dependencies and reintroduced them one-by-one, but the problem doesn't appear for any one module in particular. For example, it happens when I include dojo/topic or one of the dom modules, but not if I only include dojo/_base/window.

I understand this bug report isn't must use without more specific steps-to-reproduce; I'll work on a test case when I have a moment. But it is happening consistently, and disappears when I downgrade.

Change History (12)

comment:1 Changed 6 years ago by dylan

Are there any pages within the Dojo tests where you also see this in action?

comment:2 Changed 6 years ago by Cormac Flynn

I haven't yet had a chance to test; I'll have some time later in the week to try to narrow it down further

comment:3 Changed 6 years ago by Colin Snover

This is going to be caused by the changed focusin event detection in dojo/on, though it should not cause such a behaviour since the test is designed to use an element that is viewport-fixed so should not cause any scrolling.

Last edited 6 years ago by Colin Snover (previous) (diff)

comment:4 Changed 6 years ago by rtasarz

Aargh. I've just reported #17645 then discovered this ticket. Yes there's position: fixed on temporary element but looks like Chrome ignores it when no coordinates are provided as well. So as I wrote in #17645, it can be fixed by adding in dojo/on.js following code on line 20:

  element.style.top = '0px';
  element.style.left = '0px';

comment:5 Changed 6 years ago by bill

#17645 is a duplicate of this ticket.

comment:6 Changed 6 years ago by bill

Component: GeneralEvents
Owner: set to Colin Snover
Status: newassigned
Summary: With Dojo 1.9.2, pages are jumping to the bottom after onload in Chrome[regression] With Dojo 1.9.2, pages are jumping to the bottom after onload in Chrome

Colin, this is from your 2536e5cd0935cc7356d584bab6ac2c73d3ad6164 (refs #17599).

comment:7 Changed 6 years ago by Colin Snover

I’m having trouble reproducing any issue with the event-focusin test case. Can someone provide a modification to that test case that demonstrates this issue?

comment:8 Changed 6 years ago by Colin Snover

Never mind, I was able to reproduce it. Sorry for the trouble. Fix forthcoming.

comment:9 Changed 6 years ago by Colin Snover <github.com@…>

Resolution: fixed
Status: assignedclosed

In 65e989efbcda628e72c9616faf11d480aacebf2f/dojo:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:10 Changed 6 years ago by Colin Snover <github.com@…>

In ab088a9741a6383495a20bc34e84403e2962ed03/dojo:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:11 Changed 6 years ago by Colin Snover

Milestone: tbd1.9.3
Priority: undecidedblocker

comment:12 Changed 6 years ago by mahays0 <mahays0@…>

In 9648ab5d2b3360dbdb340bcda3ca4831e2cecd67/dojo:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 
Note: See TracTickets for help on using tickets.