Opened 6 years ago

Closed 5 years ago

#17623 closed defect (fixed)

replace browser sniffing by feature detection as much as possible in dojox/mobile

Reported by: cjolif Owned by: Patrick Ruzand
Priority: high Milestone: 1.10
Component: DojoX Mobile Version: 1.10.0-beta1
Keywords: Cc:
Blocked By: Blocking:

Description


Change History (7)

comment:1 Changed 6 years ago by Patrick Ruzand

Owner: set to Patrick Ruzand
Status: newassigned

comment:2 Changed 6 years ago by Patrick Ruzand

Milestone: tbd1.10

comment:3 Changed 6 years ago by Patrick Ruzand

Priority: undecidedhigh

Work will be done in 1.10 for this in a 2 days timebox task.

comment:4 Changed 6 years ago by Patrick Ruzand

Resolution: fixed
Status: assignedclosed

Fixed in https://github.com/dojo/dojox/commit/0d22eaed761de940211f1d31dd63eb5cc6bc92cd (don't know why it has not been closed via the merge)

comment:5 Changed 6 years ago by bill

Type: enhancementtask

comment:6 Changed 5 years ago by Sebastien Pereira

Resolution: fixed
Status: closedreopened
Type: taskdefect
Version: 1.9.11.10.0-beta1

It causes dojox/mobile/Switch to display in black on BB7. Reverting https://github.com/dojo/dojox/blob/0d22eaed761de940211f1d31dd63eb5cc6bc92cd/mobile/_maskUtils.js solves the problem. Re-opening as a defect/regression

comment:7 Changed 5 years ago by Patrick Ruzand

Resolution: fixed
Status: reopenedclosed

The problem is not linked to this ticket. Closing it.

Note: See TracTickets for help on using tickets.