Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#1762 closed defect (worksforme)

corrupted zips for some users downloading 0.4

Reported by: dylan Owned by: alex
Priority: blocker Milestone:
Component: BuildTools Version: 0.4
Keywords: Cc:
Blocked By: Blocking:

Description

It seems some users are reporting that common decompression applications on Mac and Windows and failing to decompress our release builds. Command line decompression works as expected.

Change History (4)

comment:1 Changed 13 years ago by alex

Resolution: worksforme
Status: newclosed

I just tried downloading from the "now serving" link in Win2K on IE 6, and it opened as expected under WinZip?. Marking "works for me".

comment:2 Changed 13 years ago by bradneuberg

Resolution: worksforme
Status: closedreopened

I've had people report the same thing for me on the Really Simple History library; the reports have flowed in the last month or two. I still can't isolate what's going on, but I know it's real since it's been reported by several people for me. I can't replicate it though. I've tried compressing with different tools. I found a workaround though: offer a TAR version, which works for them. I think there is something in my web server configuration, or perhaps in their network stack, that corrupts the ZIP file. I imagine the same thing is happening for the Dojo ZIP file. Reopening ticket, since I think this is real - a workaround is to offer a TAR, which Dojo can do.

comment:3 Changed 13 years ago by alex

Resolution: worksforme
Status: reopenedclosed

we already offer tarballs of all our releases. See:

http://download.dojotoolkit.org/release-0.4.0/

Marking "works for me".

comment:4 Changed 12 years ago by (none)

Milestone: 0.4.1

Milestone 0.4.1 deleted

Note: See TracTickets for help on using tickets.