Opened 6 years ago

Closed 6 years ago

#17612 closed defect (duplicate)

Editor bold button disabled in IE9+

Reported by: haysmark Owned by: Ed Chatelain
Priority: undecided Milestone: tbd
Component: Editor Version: 1.9.1
Keywords: dohfail ie11 Cc:
Blocked By: Blocking:

Description

See:

http://archive.dojotoolkit.org/nightly/dojotoolkit/dijit/tests/editor/robot/Editor_a11y.html

The first "toolbar navigation" test, "bold", fails. The robot presses shift-tab to navigate to the undo button. When the robot tries to right-arrow to the Bold button, it can't because the rest of the toolbar disabled on the tab press.

You can recreate this manually:

  1. Load test_Editor.
  2. In the first editor with a toolbar, erase the contents and type "hello".
  3. Shift-tab to the editor toolbar.
  4. The formatting options become disabled.

Using the IE11 old browser emulation, the button does not disable in IE8 or older. The button also does not disable on other browsers. This sounds a lot like a case of has(ie)<9.

Change History (3)

comment:1 Changed 6 years ago by haysmark

Keywords: dohfail ie11 added

comment:2 Changed 6 years ago by Douglas Hays

Owner: set to Ed Chatelain
Status: newassigned

edchat, can you look into this?

comment:3 Changed 6 years ago by bill

Resolution: duplicate
Status: assignedclosed

Duplicate of #17595.

Note: See TracTickets for help on using tickets.