Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#17566 closed defect (duplicate)

IE11 dojo.isIE==false dojo.isMozilla()==true

Reported by: MaMaRo Owned by:
Priority: undecided Milestone: tbd
Component: General Version: 1.8.3
Keywords: Cc: dg
Blocked By: Blocking:

Description

hi,

the calenderView.js doesn't work anymore with the IE11, because the browser detection of the IE11 says "i am a mozilla". In this case the calendar want to use the "XPathEvaluator" and thats not possible with the IE.

http://www.img-hoster.de/uploads/2013/11/i1881byu7c4.png

Attachments (1)

ieIE.PNG (143.8 KB) - added by MaMaRo 6 years ago.
Test IE11

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by MaMaRo

Attachment: ieIE.PNG added

Test IE11

comment:1 Changed 6 years ago by bill

Resolution: duplicate
Status: newclosed

Duplicate of #17311.

comment:2 Changed 6 years ago by Eugene Lazutkin

In this particular case shouldn't we check for XPathEvaluator (a feature) rather than for IE (a browser)?

comment:3 Changed 6 years ago by bill

Cc: dg added
Note: See TracTickets for help on using tickets.