Opened 5 years ago

Closed 5 years ago

#17563 closed defect (wontfix)

Dojo 1.6.2 layout breaks in IE9

Reported by: Wouter Hager Owned by: Wouter Hager
Priority: undecided Milestone: tbd
Component: Dijit Version: 1.6.2
Keywords: Cc:
Blocked By: Blocking:

Description

There is a regression in dojo 1.6.1 to 1.6.2 for layout widgets in IE9. The positioning of dijit.layout.BorderContainer? children is incorrect.

Change History (5)

comment:1 Changed 5 years ago by dylan

Owner: set to Wouter Hager
Status: newpending

Please be more specific. What is broken exactly? Is there a test case, or is this an issue with various Dojo examples, etc.?

comment:2 Changed 5 years ago by Wouter Hager

Status: pendingnew

Well after extensive testing I found that setting a margin:auto on a BorderContainer? child leads to faulty calculations.

comment:3 Changed 5 years ago by bill

Status: newpending

I tried it in the latest code and it works fine for me. This was on IE10 but set to IE9 emulation mode. If you have a test case that still fails w/the latest code you can attach it if you like, although the easier approach would be to just not set margin:auto.

comment:4 Changed 5 years ago by Wouter Hager

Status: pendingnew

No it doesn't work in IE10 with settings for 9, only if you have the actual version. I know how to fix it now, but I would still consider it a regression.

comment:5 Changed 5 years ago by bill

Resolution: wontfix
Status: newclosed

OK, perhaps... it's difficult for me to confirm since I would need to reinstall Windows to get back to IE9. Anyway if it only happens in IE9 (I confirmed it doesn't happen in IE8 or IE10), and there's a simple workaround, then it's not worth changing the code. (It's also unclear if it still happens in 1.9 or not.)

Note: See TracTickets for help on using tickets.