Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#17529 closed defect (fixed)

[regression] document.domain does not work with dijit/Editor in IE<11

Reported by: Colin Snover Owned by: Colin Snover <github.com@…>
Priority: high Milestone: 1.7.6
Component: Dijit Version: 1.7.5
Keywords: Cc:
Blocked By: Blocking:

Description

The changeset [27128], for ticket #14324, removed code required for supporting document.domain in IE. After this change, attempting to use dijit/Editor in a frame that sets document.domain causes "Access is denied." errors. This issue appears to be fixed in IE11, which works the same as all other browsers.

Patch forthcoming.

Change History (16)

comment:1 Changed 5 years ago by Colin Snover <github.com@…>

Owner: set to Colin Snover <github.com@…>
Resolution: fixed
Status: newclosed

In 31b55d02d4fc888c420396b00b9ae4282cd4e4c2/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:2 Changed 5 years ago by Colin Snover <github.com@…>

In 644a6f28d789f0a923c6f1e21c75bdfe200250bd/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:3 Changed 5 years ago by Colin Snover <github.com@…>

In 268c751ba8982ab293c8fa6ddfb51bf54c799665/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:4 Changed 5 years ago by Colin Snover <github.com@…>

In 730d18d0e52b8a4c6b483bd25210763905c03528/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:5 Changed 5 years ago by Colin Snover

Milestone: tbd1.7.6
Version: 1.9.11.7.5

comment:6 Changed 5 years ago by mahays0 <mahays0@…>

In 53a768721ff2a176c4c5025e1d83cc6ad6baf4ad/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:7 Changed 5 years ago by bill

Resolution: fixed
Status: closedreopened

This change on the 1.7 branch breaks some or all of the editor regression tests on IE10. For example, Editor_a11y.html and Editor_mouse.html. When the test starts it gets a "Incorrect function" error and nothing shows up on the screen.

comment:8 Changed 5 years ago by bill

Milestone: 1.7.61.8.6
Resolution: fixed
Status: reopenedclosed

Anyway, I rolled this back temporarily on 1.7 in e2a14e70f45c88b54dfe0741f54be5b3acb6ffa5. You can add it back when you have a solution where the tests run. Or we can just say that it's fixed starting in 1.8.

comment:9 Changed 5 years ago by Colin Snover

OK

comment:10 Changed 5 years ago by Colin Snover

Milestone: 1.8.6
Resolution: fixed
Status: closedreopened

The fix here did not work in all cases as you noted; not just a 1.7 issue, but in IE9/10 there are some additional edge cases that need to be handled. I will fix 1.7 at the same time.

comment:11 Changed 5 years ago by Colin Snover

Re: the 1.7 issue, looks like I missed a cherry-pick of 31782ca326dc6ced92ff7d78db30f64474fe35a9 which changed something else later in the file and stopped it from working. Also, because the hang is related to zone security settings, different machines will respond differently if their security zone settings are different. Re-reverted and pushed with the second fix, works OK.

comment:12 Changed 5 years ago by Colin Snover <github.com@…>

In e63d4a181ff02ed40dc6bbe9c5cca4bf208d4cec/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:13 Changed 5 years ago by Colin Snover <github.com@…>

In 33b65e728bdcc745fb1454a56d931c82c7d07e9e/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:14 Changed 5 years ago by Colin Snover <github.com@…>

In 449ba49201567834201c1e16727ddc95ef35320f/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:15 Changed 5 years ago by Colin Snover

Milestone: 1.7.6
Resolution: fixed
Status: reopenedclosed

OK, that should finally be it for this crap. Looking forward to never having to deal with this again.

comment:16 Changed 5 years ago by bill

Yes, that's working better, thanks.

Note: See TracTickets for help on using tickets.