Opened 5 years ago

Closed 5 years ago

#17523 closed defect (fixed)

DojoX Calendar, resize() not implemented for SimpleColumnView

Reported by: Arlo White Owned by: dg
Priority: undecided Milestone: 1.9.2
Component: Dojox Version: 1.9.1
Keywords: Cc:
Blocked By: Blocking:

Description

I have a Calendar that just uses SimpleColumnView?. I'm using this Calendar in a TabContainer? and BorderContainer?. I'm having trouble setting it's height through resize().

resize() does not seem to be implemented in ViewBase?.js

There are actually two resize declarations: ViewBase?.js:197, ViewBase?.js:856 Both do nothing.

In addition, CalendarBase?.js swallows any arguments to resize. I'm not sure if this is by design?

I've ended up just setting the Calendar.domNode height manually to get my Calendar to display within TabContainer/BorderContainer?.

Change History (5)

comment:1 Changed 5 years ago by Arlo White

Besides the minor ViewBase?.js duplication, I think this bug can be disregarded. I did not have height set correctly. So I guess resize() does not need to be implemented.

I forgot to set height: 100% when putting the Calendar into a BorderContainer?. This scrolls correctly if the Calendar.height < BorderContainer?.height

When viewing in my TabContainer?, I have doLayout: false, so I need to set an absolute height on the Calendar.

comment:2 Changed 5 years ago by bill

Component: DojoX WidgetsDojox
Owner: set to dg
Status: newassigned

Giving to dg to review anyway...

comment:3 Changed 5 years ago by dg

I created an issue on GitHub? for this: https://github.com/damiengarbarino/dojo-calendar/issues/76

The replication is harmless but, of course, will be removed.

The Calendar has to apply the size passed as parameter.

Meanwhile setting height and width to 100% to the calendar usually solves this kind of issue.

Regards,

Damien

comment:4 Changed 5 years ago by dg

Fixed for 1.9.2

comment:5 Changed 5 years ago by cjolif

Milestone: tbd1.9.2
Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.