Opened 6 years ago

Closed 6 years ago

#17520 closed defect (invalid)

dojo.js in Firefox 24.0 - TypeError: "undefined" is read-only

Reported by: Matthew Kwasnicki Owned by: Matthew Kwasnicki
Priority: undecided Milestone: tbd
Component: General Version: 1.8.4
Keywords: Cc:
Blocked By: Blocking:

Description

When loading dojo applications in Firefox 24.0 using the Google API link the type error: '"undefined" is read-only' halts further script processing. Confirmed in two separate applications (internal work applications) via Firebug one using dojo version 1.8.4 the other using version 1.7.2.

Change History (3)

comment:1 Changed 6 years ago by bill

Owner: set to Matthew Kwasnicki
Status: newpending

OK. Can you attach a small test case using the attach file button?

comment:2 Changed 6 years ago by Matthew Kwasnicki

Status: pendingnew

I wasn't able to recreate the problem with a simple test case, so tried to trace the problem by using a local copy of dojo with one of my applications. It turns out that the real problem was that I had the faulty Dojo Firebug extension enabled. Once I removed the extension, the problem magically disappeared.

The ticket can be closed.

comment:3 Changed 6 years ago by bill

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.