Opened 6 years ago

Closed 6 years ago

#17504 closed defect (fixed)

Tabcontainer: title change in nested tabs created tooltip for sub tabs in Chrome

Reported by: mkolonay Owned by: bill
Priority: undecided Milestone: 1.10
Component: Dijit Version: 1.9.1
Keywords: Cc:
Blocked By: Blocking:

Description

Changing the title of a tabcontainer that has another tabcontainer nested beneath it causes a tooltip with the new title text to appear when the mouse is hovered over the nested tabs.

Code example here:

http://dojo-sandbox.net/public/b75ed/1

Change History (3)

comment:1 Changed 6 years ago by bill

Component: GeneralDijit
Owner: set to bill
Summary: Tabcontainer title change in nested tabs created tooltip for sub tabs in ChromeTabcontainer: title change in nested tabs created tooltip for sub tabs in Chrome

OK, thanks, yes I see the failure in your linked test case.

comment:2 Changed 6 years ago by bill

Milestone: tbd1.10
Status: newassigned

_WidgetBase.set() has automatic mapping from widget property to DOMNode attribute, so setting a TabContainer?'s title property automatically sets TabContainer?.domNode.title. It doesn't happen for ContentPane? because ContentPane? has this code:

// Cancel _WidgetBase's _setTitleAttr because we don't want the title attribute (used to specify
// tab labels) to be copied to ContentPane.domNode... otherwise a tooltip shows up over the
// entire pane.
_setTitleAttr: null,

So, the workaround is to call nestedTabContainer.domNode.removeAttribute("title") after changing the nested TabContainer?'s title.

I'll check in a fix though.

Note that I can reproduce this on test_TabContainer.html, on the first TabContainer?. While dijit.byId("tab2").set("title", "foo") merely sets the ContentPane?'s title property, dijit.byId("inlined").set("title", "foo") sets the TabContainer?.domNode's title attribute.

comment:3 Changed 6 years ago by Bill Keese <bill@…>

Resolution: fixed
Status: assignedclosed

In 7b0ee8dc41a4df7a5688cba444c8ca46c78cdb22/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 
Note: See TracTickets for help on using tickets.