Opened 6 years ago

Closed 3 years ago

#17498 closed defect (fixed)

has("opera") fails with Opera 16

Reported by: Patatruc Owned by: dylan
Priority: low Milestone: 1.9.8
Component: Core Version: 1.9.1
Keywords: Cc:
Blocked By: Blocking:

Description

It returns 'undefined'.

Change History (6)

comment:1 Changed 6 years ago by bill

Probably since Opera is now using the webkit rendering engine.

comment:2 Changed 6 years ago by patatruc

Yes, the new user agent for Opera 15 and beyond is described here : http://my.opera.com/ODIN/blog/2013/07/15/opera-user-agent-strings-opera-15-and-beyond

(no more "opera", but "OPR").

comment:3 Changed 5 years ago by bill

#17582 is a duplicate of this ticket.

comment:4 Changed 3 years ago by dylan

Component: GeneralCore

comment:5 Changed 3 years ago by dylan

Milestone: tbd1.11
Owner: set to dylan
Status: newassigned

comment:6 Changed 3 years ago by dylan

Milestone: 1.111.9.8
Priority: undecidedlow
Resolution: fixed
Status: assignedclosed

Fixed in https://github.com/dojo/dojo/commit/09e2d02be79ae88699a097ebae615ad031eb9562 (master), https://github.com/dojo/dojo/commit/8a819c59839e16be3de88d26e7d8348a850b2a2e (1.10), and https://github.com/dojo/dojo/commit/3948aa6cd4f8e3a7221023616f41d148ddf23b1d (1.9).

Note that modern opera really should not be treated the same as old opera, so I've made the feature test be has('opr') for modern opera.

Note: See TracTickets for help on using tickets.