Opened 6 years ago

Closed 6 years ago

#17496 closed defect (invalid)

dijit tree issue and drag and drop not working in dojo 1.7.2 version

Reported by: dojo_deb Owned by:
Priority: undecided Milestone: tbd
Component: Dijit Version: 1.7.0
Keywords: Cc:
Blocked By: Blocking:

Description

Hi Dojo team,

I am using dojo 1.7.2 version in my jsp page.

1) I have written a small function in my dojo tree code as attached below to add new child folder manually under any folder present in the tree as its parent of the tree structure but it is not working. It is opening till the prompt "Folder name", after that when I add the folder name and click on ok, it is not saving in the folder tree structure. Can you suggest where it is going wrong? I am trying to wrap observable for ItemFileWriteStore? but it is not working.

It is working until alert("I am final"); in myFunction(item) after that the store.put(item) isn't working.Can you suggest what is going wrong here? I have attached the sample code I used along with the ticket .

2) Also the drag and drop feature is not working. It is dragging the folder but not dropping any folder structure. Is the drag and drop not working due to some bug?How can I fix this issue, please help. Appreciate for all your help in this.

Kind regards deb

Change History (2)

comment:1 Changed 6 years ago by bill

#17497 is a duplicate of this ticket.

comment:2 Changed 6 years ago by bill

Resolution: invalid
Status: newclosed

Note: test case is in #17497.

Sorry, but we can't take support requests in the bug database. I suggest you try your question on the dojo-interest mailing list if you haven't already.

Note: See TracTickets for help on using tickets.