Opened 6 years ago

Closed 6 years ago

#17490 closed defect (invalid)

A11y - dijit.Tree

Reported by: pierpaolo.manca Owned by: pierpaolo.manca
Priority: undecided Milestone: tbd
Component: Dijit Version: 1.7.3
Keywords: Cc:
Blocked By: Blocking:

Description

The dojo tree does not meet all the A11y requirements. Problem details:

  • An element having a role must reference valid global or widget WAI-ARIA properties;
  • Multiple elements having a WAI-ARIA group role must have unique labels specified with aria-label or aria-labelledby;
  • A WAI-ARIA widget must have an accessible name specified with aria-label, aria-labelledby or the widget's inner text.

Change History (2)

comment:1 Changed 6 years ago by bill

Owner: set to pierpaolo.manca
Status: newpending

You'll need to be more specific. You need to say the exact DOMNode where the problem is, and then say what attributes should be set on that DOMNode to fix the problem.

comment:2 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.