Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#1749 closed defect (worksforme)

Removal of last TreeNodeV3 in a TreeV3 displays wrong image in front of it

Reported by: guest Owned by: ilia
Priority: high Milestone:
Component: Widgets Version: 0.4
Keywords: TreeV3 TreeNodeV3 removal Cc:
Blocked By: Blocking:

Description

If you have a TreeV3 tree with TreeNodeV3 nodes in it and you remove the last node in a branch the small image in front of the node *above* the removed node doesn't change to look like the new last node.

Let's see, can I add a picture to this ticket?

Attachments (1)

tree_chop.jpg (4.1 KB) - added by guest 13 years ago.
Picture of a tree after the last node has been removed.

Download all attachments as: .zip

Change History (6)

Changed 13 years ago by guest

Attachment: tree_chop.jpg added

Picture of a tree after the last node has been removed.

comment:1 Changed 13 years ago by bill

Milestone: 0.4.10.5

comment:2 Changed 13 years ago by bill

Milestone: 0.50.4.1

Since Alex decided that TreeV3 shouldn't be marked experimental, except for the DnD part, we need to do this for 0.4.1.

comment:3 Changed 13 years ago by ilia

Status: newassigned

That really needs some review.. I couldn't reproduce it. A test case is welcome.

comment:4 Changed 13 years ago by jkuhnert

Resolution: worksforme
Status: assignedclosed

Couldn't reproduce any supposed bad behavior. If someone can supply a test case along with expected / actual results we might be able to figure out what the possible problem is.

comment:5 Changed 12 years ago by (none)

Milestone: 0.4.1

Milestone 0.4.1 deleted

Note: See TracTickets for help on using tickets.