Opened 6 years ago

Closed 6 years ago

#17483 closed defect (invalid)

A Chart with a StoreSeries based on an Observable which wrappes a Store that returns Deferreds may not be updated upon changes to the (observable) store.

Reported by: josbraaksma Owned by:
Priority: undecided Milestone: tbd
Component: Dojox Version: 1.9.1
Keywords: Cc:
Blocked By: Blocking:

Description

dojo/store/Observable does not recognise that its store may return a Deferred early enough. Results will not get observed and a querypdater not created. This causes problems down the line:

dojox/charting/StoreSeries checks foro a results observeability outside its Deferrred.when block, the Deferred not having an observe causes the StoreSeries? not to be updated ever. Moving the observe check within the Deferred.when blcok fixes this.

attached file shows the problem.

https://github.com/dojo/dojox/pull/42 https://github.com/dojo/dojo/pull/30

Attachments (1)

index.html (1.6 KB) - added by josbraaksma 6 years ago.

Download all attachments as: .zip

Change History (2)

Changed 6 years ago by josbraaksma

Attachment: index.html added

comment:1 Changed 6 years ago by ben hockey

Resolution: invalid
Status: newclosed

based on https://github.com/dojo/dojo/pull/30#commitcomment-4222957 i'm closing this since it's working as designed.

Note: See TracTickets for help on using tickets.