Opened 13 years ago

Closed 12 years ago

#1747 closed defect (fixed)

Tooltip fails for long spans

Reported by: bill Owned by: bill
Priority: high Milestone: 0.9beta
Component: Dijit Version: 0.4
Keywords: Cc:
Blocked By: Blocking:

Description (last modified by bill)

This is based on #1125.

Tooltip won't work for multi-line spans. Thus, tooltip won't work for long spans, and also, users need to force short spans to one line w/appropriate CSS (text-wrap: nobreak or something like that).

It's because Tooltip uses dojo.html.overElement() rather than watching onMouseOut/onMouseOver events, in order to avoid getting confused by spurious onMouseOut/onMouseOver events caused by the explode effect. The explosion starts from the mouse position, thus temporarily covering up the element the tooltip is attached to, thus causing spurious onMouseOver/onMouseOut events.

Change History (3)

comment:1 Changed 13 years ago by bill

Description: modified (diff)

comment:2 Changed 12 years ago by bill

Component: WidgetsDijit
Milestone: 0.91.0

comment:3 Changed 12 years ago by bill

Milestone: 1.00.9beta
Resolution: fixed
Status: newclosed

For dijit 0.9, multi line spans are working, and we are monitoring onMouseOver/onMouseOut events. (We are also using fade rather than explosions to show the tooltips, which avoids a lot of this issue.)

Note: See TracTickets for help on using tickets.