Opened 6 years ago

Closed 6 years ago

#17452 closed defect (invalid)

Dojox form manager - gatherFormValues() and reset() methods

Reported by: dojonovice@… Owned by:
Priority: undecided Milestone: tbd
Component: DojoX Form Version: 1.9.1
Keywords: Cc:
Blocked By: Blocking:

Description

gatherFormValues is buggy.

registry found dfm widget but gatherFormValues() returns "empty" object. Same with reset() method. All methods are visible and available.

some dfm widgets works with gatherFormValues() and some not. gatherFormValues returns only: Object {ownerDocumentBody: null, formNode: null} but formNode exists.

How I tested: I inserted breakpoint inside one of methods. I applied registry.byId() for widget connections. dfm widgets that works properly worked properly from this method too. Problematic dfm widgets was found, all method were accessible but no results.

attaching parsed widget, can not reproduce it as standalone sample due to large project and logic. Maybe you find what is wrong. All dfm widgets are siblings.

<form id="addFormuniqName_9_26" data-dojo-type="dojox/form/Manager" data-dojo-attach-point="formNode" widgetid="addFormuniqName_9_26">

<div data-dojo-attach-point="containerNode" style="opacity: 1; height: auto;"><div id="uniqName_10_7" widgetid="uniqName_10_7">

<div class="details">

<section>

<section>

<label for="notizName">Name:</label> <textarea name="name" data-dojo-attach-point="focusNode,containerNode,textbox" autocomplete="off" class="form-control dijitTextBox dijitTextArea dijitExpandingTextArea" tabindex="0" id="notizName" widgetid="notizName" value="" style="overflow-y: hidden; overflow-x: auto; box-sizing: border-box; height: 22px;" rows="1"></textarea> <label for="notizSubject">Subject:</label> <textarea name="subject" data-dojo-attach-point="focusNode,containerNode,textbox" autocomplete="off" class="form-control dijitTextBox dijitTextArea dijitExpandingTextArea" tabindex="0" id="notizSubject" widgetid="notizSubject" value="" style="overflow-y: hidden; overflow-x: auto; box-sizing: border-box; height: 22px;" rows="1"></textarea> <label for="notizNote">Note:</label> <textarea name="note" data-dojo-attach-point="focusNode,containerNode,textbox" autocomplete="off" class="form-control dijitTextBox dijitTextArea dijitExpandingTextArea" tabindex="0" id="notizNote" widgetid="notizNote" value="" style="overflow-y: hidden; overflow-x: auto; box-sizing: border-box; height: 22px;" rows="1"></textarea>

</section>

</section>

</div>

</div></div>

</form>

Change History (2)

comment:1 in reply to:  description Changed 6 years ago by dojonovice@…

Fixed.

Widgtes's startup method has not this.inherited(arguments);

comment:2 Changed 6 years ago by bill

Resolution: invalid
Status: newclosed

Widgtes's startup method has not this.inherited(arguments);

I don't know what widget you are talking about, but since dojox/form/Manager.js doesn't have a startup method, I'm going to assume it was a problem in your custom widget.

Note: See TracTickets for help on using tickets.