Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#17428 closed defect (fixed)

Fieldset: Tab navigation problems on Chrome, Safari

Reported by: blah238 Owned by: bill
Priority: undecided Milestone: 1.9.4
Component: Dijit Version: 1.9.1
Keywords: Cc:
Blocked By: Blocking:

Description

Problem 1: On Chrome, tab navigation (either direction) does not focus the expand/collapse arrow at the top-left of dijit.FieldSet? widgets

Problem 2: On Chrome, reverse tab navigation (shift-tab) stops at the first input field within any dijit.FieldSet? widget. Forward tab navigation does not have the same issue.

Example: http://jsfiddle.net/blah238/GCswY/

Attachments (1)

legend.html (434 bytes) - added by bill 5 years ago.
plain html test case showing problem on chrome and safari

Download all attachments as: .zip

Change History (8)

comment:1 Changed 6 years ago by bill

Component: DojoX WidgetsDijit
Owner: set to bill
Status: newassigned
Summary: Tab navigation problems with dijit.FieldSet on ChromeFieldset: Tab navigation problems on Chrome

Hmm, that's an odd one. Seems like a webkit bug, since it works on firefox and since the <label> does have tabIndex=0. Also peculiar is that the test case I checked in (dijit/tests/Fieldset.html) does work on Chrome.

comment:2 Changed 5 years ago by bill

Owner: changed from bill to blah238
Status: assignedpending

I just tried it on both mac and WinXP. It's working for me, at least for the Fieldset.html test. Do you have a test case that reproduces the problem?

comment:3 Changed 5 years ago by bill

Milestone: tbd1.10
Owner: changed from blah238 to bill
Status: pendingassigned

Oh sorry, I forgot you attached the fiddle (where the problem does reproduce). I'll take a look again.

comment:4 Changed 5 years ago by bill

Summary: Fieldset: Tab navigation problems on ChromeFieldset: Tab navigation problems on Chrome, Safari

Note that problem happens on plain markup too, so it's a bug in webkit (that now got copied over to the blink fork). See legend.html attachment for plain HTML test case.

Changed 5 years ago by bill

Attachment: legend.html added

plain html test case showing problem on chrome and safari

comment:5 Changed 5 years ago by Bill Keese <bill@…>

Resolution: fixed
Status: assignedclosed

In 1a124a2adfbaaedefa335e2e87aee23652132e22/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:6 Changed 5 years ago by bill

Milestone: 1.101.9.4

comment:7 Changed 5 years ago by Bill Keese <bill@…>

In 1bfec2d4064541214b041aca74921dff0dc99278/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 
Note: See TracTickets for help on using tickets.