Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#17418 closed defect (fixed)

ScrollablePane round corners are not correctly displayed on IE10+ and Firefox

Reported by: Sebastien Brunot Owned by: Adrian Vasiliu <vasiliu@…>
Priority: undecided Milestone: 1.10
Component: DojoX Mobile Version: 1.9.1
Keywords: Cc:
Blocked By: Blocking:

Description

See the attached picture of the test page dojox/mobile/tests/test_ScrollablePane-mask.html displayed on IE11.

The problem is related to the SVG mask created in IE and firefox to display round corners.

Attachments (1)

screenshot.png (73.3 KB) - added by Sebastien Brunot 6 years ago.

Download all attachments as: .zip

Change History (6)

Changed 6 years ago by Sebastien Brunot

Attachment: screenshot.png added

comment:1 Changed 6 years ago by Sebastien Brunot

The problem is that the _maskUtils.createRoundMask method is not retrieving the correct background color of the body element when running (it retrieves 'transparent' instead of the expected rgb(197, 204, 211) value. As a consequence, the stoke and fill color for the rgb mask has the incorrect value 'undefined'.

The color is not retrieved because the CSS class mblBackground has not yet been applied to the body element when the _maskUtils.createRoundMask method is executed.

comment:2 Changed 6 years ago by Sebastien Brunot

The workaround is to set parseOnLoad to false, and to trigger the parse inside dojo/ready:

ready(function(){

parser.parse();

});

comment:3 Changed 6 years ago by Sebastien Brunot

A pull request has been created for a fix under IBM CCLA: https://github.com/dojo/dojox/pull/34

Last edited 6 years ago by Sebastien Brunot (previous) (diff)

comment:4 Changed 6 years ago by Adrian Vasiliu <vasiliu@…>

Owner: set to Adrian Vasiliu <vasiliu@…>
Resolution: fixed
Status: newclosed

In 39786820cc6078106dd9c7fc1a0e70aeb97e6d77/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:5 Changed 6 years ago by bill

Milestone: tbd1.10
Note: See TracTickets for help on using tickets.