Opened 6 years ago

Closed 5 years ago

#17417 closed defect (fixed)

IE11 support

Reported by: Sebastien Brunot Owned by: Sebastien Brunot
Priority: undecided Milestone: 1.9.2
Component: DojoX Mobile Version: 1.9.1
Keywords: ie11 Cc:
Blocked By: Blocking:

Description (last modified by Sebastien Brunot)

Running the manual tests of dojox/mobile using the current master branch, a few issues appeared:

1) The default theme (iPhone) is used in the tests, not the windows phone test (deviceTheme.js needs to be updated for IE11).

2) test_DataCarousel-demo.html: rendering problem with the detailed images (note that the same problem is reproduced using IE10)

3) test_iconContainer-connect.html: in Edit mode, there is a visual glitch (black bars leff and right of the icons). When stopping the edit mode, the icons continues to shake.

Change History (13)

comment:1 Changed 6 years ago by Sebastien Brunot

Owner: set to Sebastien Brunot
Status: newassigned

comment:2 Changed 6 years ago by cjolif

Keywords: ie11 added

comment:3 Changed 6 years ago by Sebastien Brunot

Description: modified (diff)

comment:4 Changed 6 years ago by Sebastien Brunot

Description: modified (diff)

comment:5 Changed 6 years ago by Adrian Vasiliu <vasiliu@…>

Resolution: fixed
Status: assignedclosed

In bd6a44b9ca37ada7700d021f6717f64ad1eaf232/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:6 Changed 6 years ago by Adrian Vasiliu <vasiliu@…>

In 55339e80fc88d6669e5a968e743e9f995a1de64c/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:7 Changed 6 years ago by Adrian Vasiliu

Milestone: tbd1.9.2

comment:8 Changed 6 years ago by Sebastien Brunot

Resolution: fixed
Status: closedreopened

comment:9 Changed 6 years ago by Sebastien Brunot

There are still some issues after the first patch:

  • test_Carousel-prog.html: ERROR: SwapView?.js line 95: Object doesn't support property or method '_fingerMovedSinceTouchStart'
  • test_Overlay.html: click 'pop up' and then 'done' -> a grey area is still displayed on screen, masking the 'pop up' and 'pop down' buttons.
Last edited 6 years ago by Sebastien Brunot (previous) (diff)

comment:10 Changed 6 years ago by Adrian Vasiliu

For the first one: indeed. More exactly, the first issue is not due to the fix of this ticket but to the fix of #17416. For this one, the fix is obvious, there's no need to redo the PR sbrunot. I'll commit the fix soon. Edit: done.

For the second one: what browser/device? In master? or in the 1.9 branch? I've tried in master on a few desktop and mobile browsers without reproducing. And do you think you'll have a fix for it? Is it a regression introduced by the patch?

Last edited 6 years ago by Adrian Vasiliu (previous) (diff)

comment:11 Changed 6 years ago by Sebastien Brunot

Thanks Adrian. I've also submitted pull request 40 (https://github.com/dojo/dojox/pull/40) to fix the second issue.

comment:12 Changed 6 years ago by Adrian Vasiliu

Okay, so the second issue is specific to IE11. (I reproduce on Iconia W510 IE11-preview). You didn't answer whether it's a regression introduced by the patch, but after all this doesn't change the picture that much. I'm working on your PR.

comment:13 Changed 5 years ago by Adrian Vasiliu

Resolution: fixed
Status: reopenedclosed

This second issue looks as an IE11-preview bug, and the suggested workaround is unclean. Hence, we'll wait till IE11 will be out. Since the issue is not a regression introduced by the patch in this ticket, I'm closing the ticket again. Can be entered as a distinct ticket if appropriate.

Note: See TracTickets for help on using tickets.