Opened 6 years ago

Closed 5 years ago

#17385 closed defect (fixed)

dojox.Calendar misbehaves on Firefox 22.0, 23.0

Reported by: Liubomir Armoutliev Owned by: dg
Priority: undecided Milestone: 1.9.2
Component: Dojox Version: 1.9.0
Keywords: Cc:
Blocked By: Blocking:

Description

The following div is preventing the user to create events.

<div style="position: absolute; left:0; right:0; bottom:0; top:0; z-index:30; tabIndex:-1; background-image:url('../../dojo/resources/blank.gif'); cursor: n-resize"></div>

If given display:none to the div - still unable to resize and move events.

With Chrome this is not happening.

With version 1.8.3 this is not happening.

The misbehavior started with version 1.9.0. The same with version 1.9.1

Can be seen at the demos/calendar/demo.html also

Change History (7)

comment:1 Changed 6 years ago by Liubomir Armoutliev

The div is created in dojox.calendar.ViewBase?._onItemEditBeginGesture in the body of the following condition :

if (!e.isDefaultPrevented()){

...

comment:2 Changed 6 years ago by bill

Owner: set to dg
Status: newassigned

comment:3 Changed 5 years ago by tombo

"mouseup" event registered in onRendererHandleMouseDown (mouse.js) which should call editingMouseUpHandler is never fired and it cause that the div (_edProps.editLayer) is still present ( no _onItemEditEndGesture call )

in SimpleColumnView?.js function _createRenderData :

remove _endItemEditing will fix this blocking behavior, but I don't deeply understand dojox.calendar so it may cause another unexpected problems. if(this._isEditing){

this._endItemEditing(null, false); <--comment this line

}

Last edited 5 years ago by tombo (previous) (diff)

comment:4 Changed 5 years ago by dg

Hi,

No you cannot comment this otherwise editing will never end and will never commit new values.

It seems to be related to an invalid state of the widget where the gesture is marked not finished.

I committed some fixes to the calendar on the github, could you try it and check if it solves your issue: https://github.com/damiengarbarino/dojo-calendar/tree/dojo1.9

Thanks,

Damien

comment:5 Changed 5 years ago by dg

As there's no feedback and that I cannot reproduce anymore with the latest changes, I delivered the fix for 1.9.2. IMHO, we can close the ticket.

comment:6 Changed 5 years ago by Liubomir Armoutliev

I tested the fix also, with it the calendar is working as expected

comment:7 Changed 5 years ago by cjolif

Milestone: tbd1.9.2
Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.