Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#17371 closed defect (fixed)

CheckedMenuItem: disabled state no longer visible

Reported by: dgerhardt Owned by: bill
Priority: undecided Milestone: 1.9.2
Component: Dijit Version: 1.9.1
Keywords: Cc:
Blocked By: Blocking:

Description

While the interaction with disabled CheckedMenuItems? is not possible as it should be, the state is no longer shown to the user since Dojo 1.9. The text color does not change and the icon is not swapped.

Sample code to reproduce the issue is available under https://gist.github.com/dgerhardt/6194137.

Attachments (1)

sample-17371.html (1.2 KB) - added by dgerhardt 6 years ago.
Code sample demonstrating the issue

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by dgerhardt

Attachment: sample-17371.html added

Code sample demonstrating the issue

comment:1 Changed 6 years ago by bill

Milestone: tbd1.9.2
Owner: set to bill
Status: newassigned

OK thanks, I'll fix, looks like I broke it in 08c0010ee23b842578f7bef1c7ee52b6908dca14.

comment:2 Changed 6 years ago by Bill Keese <bill@…>

Resolution: fixed
Status: assignedclosed

In d1c28853cb5557ee5d3abb8f6c730814819b231e/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:3 Changed 6 years ago by Bill Keese <bill@…>

In a2cea0d21b89d782e0fbe228b86902118f168057/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 
Note: See TracTickets for help on using tickets.