Opened 6 years ago

Closed 5 years ago

#17351 closed defect (invalid)

Charting & tooltip in canvas mode results into performance issue

Reported by: Evan Owned by: Evan
Priority: undecided Milestone: tbd
Component: Charting Version: 1.9.1
Keywords: Cc:
Blocked By: Blocking:

Description

Using Charting with Tooltip & Magnify in canvas mode will cause significant performance regression in 1.9.1

The attached test case created 3 Series with total 150 anchor tooltips, running this in canvas mode will result into a significant performance issue e.g. make FF V.22 frozen.

This issue doesn't happen when running in svg mode, neither happened in 1.8.1 where in canvas mode there is some latency when hovering the anchor compared with svg(guess due to position calculation), but overall it's still running well.

Attachments (1)

17351.html (2.0 KB) - added by Evan 6 years ago.

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by Evan

Attachment: 17351.html added

comment:1 Changed 6 years ago by cjolif

Evan, have you tried to set canvasWithEvents:false to see if the problem is not coming from the canvas event implementation instead of charting. Charting does not need it so you can disable it and maybe this is the cause of the problem.

comment:2 Changed 5 years ago by cjolif

Owner: set to Evan
Status: newpending

comment:3 Changed 5 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.