Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#17313 closed defect (duplicate)

Hovering over a MenuSeparator in a programmatically generated Menu causes an error.

Reported by: mwernsing Owned by:
Priority: undecided Milestone: tbd
Component: Dijit Version: 1.8.5
Keywords: Cc:
Blocked By: Blocking:

Description

To reproduce:

  1. Open dijit/tests/test_Menu.html
  2. Click on "create programmatic menu" button
  3. Right click on div with blue outline
  4. Move mouse over menu until over the first MenuSeparator?
  5. Error at: widget.focus(last ? "end" : "start"); in _KeyNavContainer in focusChild() method. Widget has no method .focus()

As mentioned in the title this error only appears to happen with a programmatically created Menu and MenuSeparator?.

Also at this point widget.isFocusable() returns "false"

Change History (2)

comment:1 Changed 6 years ago by bill

Resolution: duplicate
Status: newclosed

Duplicate of #16491.
I fixed this in 1.8.3, are you really still seeing it in 1.8.5? It's working for me, tested on chrome/mac and FF/mac.

comment:2 Changed 6 years ago by mwernsing

Turns out I'm actually using 1.8.2. Sorry for the inconvenience.

Note: See TracTickets for help on using tickets.