Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#17311 closed defect (wontfix)

has("ie") fails with IE11

Reported by: Gordon Smith Owned by: haysmark
Priority: blocker Milestone:
Component: Core Version: 1.9.1
Keywords: ie11 Cc:
Blocked By: Blocking:

Description

has("ie") returns false when called within IE11

Change History (62)

comment:1 Changed 6 years ago by haysmark

Looks like they removed document.all and MSIE from the UA string.

comment:3 Changed 6 years ago by haysmark

Yes saw that too, I submitted a pull request using the Trident sniff.

comment:4 Changed 6 years ago by dante

I worry that things using has("ie") should be using proper feature tests, and that making ie11 go into branches where the implication is made will cause future pain. I agree having a stable way to identify IE is good, I'm just commenting on code that I don't even know exists, eg:

if(has("ie")){
    document.attachEvent(....)
}else{
    document.addEventListener(...)
}

or whatever. Wouldn't be a difficult audit.

comment:5 Changed 6 years ago by darth

I think you guys should change sniff.js to use the "Trident" token to detect IE. Likewise Opera's new UA has Chrome and Webkit in it, so perhaps that needs a change too.

Last edited 6 years ago by darth (previous) (diff)

comment:6 Changed 6 years ago by mahays0 <mahays0@…>

Owner: set to mahays0 <mahays0@…>
Resolution: fixed
Status: newclosed

In f58c0e19ce509398985908688a768c8fb41191b8/dojo:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:7 Changed 6 years ago by mahays0 <mahays0@…>

In af80d059f9070bff17e7cbf5c20daa80007d58f0/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:8 Changed 6 years ago by haysmark

Resolution: fixed
Status: closedreopened

comment:9 Changed 6 years ago by haysmark

Owner: changed from mahays0 <mahays0@…> to haysmark
Status: reopenedassigned

comment:10 Changed 6 years ago by haysmark

Resolution: fixed
Status: assignedclosed

comment:11 Changed 6 years ago by haysmark

Milestone: tbd2.0

comment:12 Changed 6 years ago by haysmark

Milestone: 2.01.10

comment:13 Changed 6 years ago by mahays0 <mahays0@…>

In fd1504c63ce4ea2a1e49c9917f8f22e78876c826/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:14 Changed 6 years ago by mahays0 <mahays0@…>

In 28e1f7c31de5a407a0c095038bf851518085bffc/dojo:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:15 Changed 6 years ago by mahays0 <mahays0@…>

In dcc794bc0a5016194058c3fc70ca23592c9bae92/dojo:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:16 Changed 6 years ago by mahays0 <mahays0@…>

In 24aa6e9f02cdd8b6dba6b2b66d3a81df7b21224d/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:17 Changed 6 years ago by haysmark

Milestone: 1.101.7.6

comment:18 Changed 6 years ago by mahays0 <mahays0@…>

In 7dca5a2e4eeaedc598d31d33a6eeaeba18f8571a/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:19 Changed 6 years ago by mahays0 <mahays0@…>

In 926898da2934cdfba9c99c11a25a8c9080811f35/dojo:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:20 Changed 6 years ago by mahays0 <mahays0@…>

In 6e032cae2ef959edcd5ee552ba58fdf397fa5ddf/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:21 Changed 6 years ago by mahays0 <mahays0@…>

In 50a5a1747a6d69afc5e2c19fe3401eb885a0b3ee/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:22 Changed 6 years ago by mahays0 <mahays0@…>

In 73ed6b808b4d70297219b6aa5754bd6b55cfbc2a/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:23 Changed 6 years ago by cjolif

Keywords: ie11 added

comment:24 Changed 6 years ago by bill

#17566 is a duplicate of this ticket.

comment:25 Changed 6 years ago by MaMaRo

Which dojo 1.8.3 libarys i have to change, that IE11 is supported ???

Upgrading to dojo 1.9.1 is no option, because Dojo 1.8.3 is included in IBM Lotus Domino 9.0.1 !

comment:26 Changed 6 years ago by cjolif

This fix has been committed in the 1.8 branch so it should end up in the next 1.8.X (1.8.6). From an IBM standpoint please check with your IBM representative and/or support contact?

Last edited 6 years ago by cjolif (previous) (diff)

comment:27 in reply to:  26 Changed 6 years ago by MaMaRo

Replying to cjolif:

This fix has been committed in the 1.8 branch so it should end up in the next 1.8.X (1.8.6). From an IBM standpoint please check with your IBM representative and/or support contact?

Thanks a lot ;) I have contact IBM Support and will keep up-to-date

comment:28 Changed 6 years ago by brianlschultz

We are having issues with dojo in IE11. I looked for these fixes in the 1.9.1 and do not see.

The main issue we notice is in ValidationTextBox?. When we have 2 or more on the page and you tab between them the IE11 browser hangs. It appears to toggle back and forth between the 2 fields.

comment:29 Changed 6 years ago by MaMaRo

the answer from IBM is "IE11 is not supported!" and they don't know when the new dojo version will be included....great :(

comment:30 Changed 6 years ago by brianlschultz

Yeah I got the same response from IBM.

From what I understand you are reporting an issue you are having with Dojo in IE11.

Please find below a link to the WebSphere? Commerce software requirements which includes a list of the supported browsers. For Internet Explorer, versions 6, 7, 8, 9 and 10 are supported.

Supported Browsers for WebSphere? Commerce Stores: http://pic.dhe.ibm.com/infocenter/wchelp/v7r0m0/topic/com.ibm.commerce.install.doc/refs/rigsrvswprereqwin.htm

Since IE11 has not been tested, unfortunately it is not something we can provide support on.

comment:31 Changed 6 years ago by brianlschultz

In order to fix the issue in the short term until dojo is fixed we added this to our pages: <meta http-equiv="X-UA-Compatible" content="IE=EmulateIE10" />

comment:32 in reply to:  31 ; Changed 6 years ago by MaMaRo

Replying to brianlschultz:

In order to fix the issue in the short term until dojo is fixed we added this to our pages: <meta http-equiv="X-UA-Compatible" content="IE=EmulateIE10" />

i will test it tomorrow, but i don't think it will work in my case :-) Thx brain

comment:33 in reply to:  28 Changed 6 years ago by bill

Replying to brianlschultz:

I looked for these fixes in the 1.9.1 and do not see.

Right, the fixes aren't in 1.9.1 since 1.9.1 was released before the IE11 beta. IE11 support will be in 1.7.6, 1.8.6, and 1.9.2.

comment:34 Changed 6 years ago by Colin Snover

Resolution: fixed
Status: closedreopened

comment:35 Changed 6 years ago by Colin Snover

Milestone: 1.7.61.9.2
Priority: undecidedblocker
Status: reopenedopen

comment:36 in reply to:  32 Changed 6 years ago by MaMaRo

Replying to MaMaRo:

Replying to brianlschultz:

In order to fix the issue in the short term until dojo is fixed we added this to our pages: <meta http-equiv="X-UA-Compatible" content="IE=EmulateIE10" />

i will test it tomorrow, but i don't think it will work in my case :-) Thx brain

okay it's working ;) Thx Brain

comment:37 Changed 6 years ago by Colin Snover <github.com@…>

Resolution: fixed
Status: openclosed

In 477d62923e7cd1e32799395301f21c008dc55de6/dojo:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:38 Changed 6 years ago by Colin Snover <github.com@…>

In 28c2050cbb7f69daa57bd66e3b740a16bb19fd75/dojo:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:39 Changed 6 years ago by Colin Snover <github.com@…>

In bbe72ecd13f5604802b2498f3623e7c5961069f4/dojo:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:40 Changed 6 years ago by Colin Snover <github.com@…>

In bb0ae352737b8994419d591c728bf962d1d0759b/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:41 Changed 6 years ago by Colin Snover <github.com@…>

In 8d884077865c16f9debe62077f8ebb2da07ee29f/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:42 Changed 6 years ago by Colin Snover <github.com@…>

In 788afa04681010da261850e81f847089826c7dba/dojo:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:43 Changed 6 years ago by Colin Snover <github.com@…>

In bad851981604b4978e406edf11ab0a23b019a859/dojo:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:44 Changed 6 years ago by Colin Snover <github.com@…>

In 769bfce2141826ed873d3eba3302227a08a43052/dojo:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:45 Changed 6 years ago by Colin Snover <github.com@…>

In 574fd141dd4ae18cd08174f4d5b892afdf7aa114/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:46 Changed 6 years ago by Colin Snover <github.com@…>

In 397c2da26c0fb18da29643ee2e8f1535246d4863/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:47 Changed 6 years ago by mahays0 <mahays0@…>

In f2c48ad6469eaebff35bc45dd27c0ea05406e9d1/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:48 Changed 6 years ago by mahays0 <mahays0@…>

In 58fac915c27e8e28e76dca762d309fcf0da24881/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:49 Changed 6 years ago by mahays0 <mahays0@…>

In 772563ca6cedfd1126def94ca3f7b35849e38a23/dojo:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:50 Changed 6 years ago by mahays0 <mahays0@…>

In fea66d3963b654a35a29ae82379f10fd64e34dfd/dojo:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:51 Changed 6 years ago by mahays0 <mahays0@…>

In 136ac4ed115997c5a88118db15d29ff706d7654e/dojo:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:52 Changed 6 years ago by haysmark

Milestone: 1.9.21.8.4

comment:53 Changed 6 years ago by Colin Snover

Milestone: 1.8.41.9.2

1.8.4 was released last May and the things that you committed to the 1.8 branch don’t make IE11 work in 1.8. This issue is still unresolved beyond 1.9 branch.

comment:54 Changed 5 years ago by fbest

Can you please set the status to REOPENED and give some information when it is going to be fixed in dojo 1.9.*?

comment:55 Changed 5 years ago by dylan

Please define fixed?

http://dojo-toolkit.33424.n3.nabble.com/Dojo-1-9-2-now-available-td4000355.html explains how IE11 support was added for Dojo 1.9.2+ , and how has('ie') will intentionally not return a value in IE11 (per Microsoft's recommendation for toolkits supporting IE11).

comment:56 in reply to:  53 Changed 5 years ago by fbest

Replying to csnover:

1.8.4 was released last May and the things that you committed to the 1.8 branch don’t make IE11 work in 1.8. This issue is still unresolved beyond 1.9 branch.

dylan: Ah ok, the comment let me think that this is not really resolved yet.

comment:57 Changed 5 years ago by bill

Milestone: 1.9.2
Resolution: fixed
Status: closedreopened

comment:58 Changed 5 years ago by bill

Resolution: wontfix
Status: reopenedclosed

The decision was made for has('ie") to return false for IE11+. Instead there's a has("trident") flag you can use.

comment:59 Changed 5 years ago by Bill Keese <bill@…>

In 83fb92c77fc908f04a8b1bf8badd75b222f059e2/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:60 Changed 5 years ago by Bill Keese <bill@…>

In 9900d06e43da47f0607bf90ad9ff4981ac1fff84/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:61 Changed 5 years ago by cubicrace

For IE11, Microsoft changed their browser's version identification. Now the navigator.useragent inspects the value as:

"Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; .NET4.0C; .NET4.0E; rv:11.0) like Gecko"

This leads to an older version of Dojo (I've seen this issue with Dojo 1.6.x) to return dojo.isIE as undefined. Dojo 1.9.3 does have support for IE 11, but we can still tweak for older Dojo versions of dojo to atleast detect the browser version for IE 11. Below is the javascript trick:

if( !dojo.isIE ) {

var userAgent = navigator.userAgent.toLowerCase(); var IEReg = /(msie\s|trident.*rv:)([\w.]+)/; var match = IEReg.exec(userAgent); if( match )

dojo.isIE = match[2] - 0;

else

dojo.isIE = undefined;

}

Here's the solution link for reference: http://www.cubicrace.com/2014/11/dojo-unable-to-detect-ie-browser.html

comment:62 Changed 5 years ago by Colin Snover

cubicrace please read comment:55.

Last edited 5 years ago by Colin Snover (previous) (diff)
Note: See TracTickets for help on using tickets.