Opened 14 years ago

Closed 13 years ago

Last modified 12 years ago

#173 closed defect (fixed)

moving the splitters in the split pane does off things with borders

Reported by: cal <cal@…> Owned by: bill
Priority: high Milestone:
Component: Widgets Version: 0.1
Keywords: Cc: peller@…, doughays@…
Blocked By: Blocking:

Description

it seems like the drag positioning for the splitters is reading positions based on border but setting them without, or some such. the end effect is that if you click and release a sizer without moving the house at all, it moves 1 pixels right/down. this doesn't seem to be related to the sizes of either the splitter border of the parent container. could be an off-by-one error somewhere in the dragging guts?

Attachments (1)

173.patch (7.2 KB) - added by doughays@… 13 years ago.
fixed calculations and removed common code - this supersedes 391.patch

Download all attachments as: .zip

Change History (6)

comment:1 Changed 14 years ago by bill

Owner: changed from anonymous to bill

Confirmed that this still happens.

comment:2 Changed 14 years ago by Tom Trenka

Milestone: 0.4

Pushing the milestone for fixing back, since that's the widget release and the splitter may have changed significantly by then.

Changed 13 years ago by doughays@…

Attachment: 173.patch added

fixed calculations and removed common code - this supersedes 391.patch

comment:3 Changed 13 years ago by doughays@…

Cc: peller@… doughays@… added

Please verify the attached patch against the trunk revision 5629

comment:4 Changed 13 years ago by bill

Resolution: fixed
Status: newclosed

(In [5631]) Fixes #173 - just clicking a splitter makes it move 1px Fixes #391 - splitContainer panels sometimes have undesired scrollbars Fixes #883 - opera: resizing fails in test_SplitContainer.html

Patch from Doug (IBM, CCLA on file)

Also, I changed activeResize to be true/false rather than 0/1. Because we're not programming in C anymore. :-)

comment:5 Changed 12 years ago by (none)

Milestone: 0.4

Milestone 0.4 deleted

Note: See TracTickets for help on using tickets.