Opened 6 years ago

Closed 6 years ago

#17299 closed defect (duplicate)

DropDownButton drop down does not close in Internet Explorer 10

Reported by: void Owned by:
Priority: undecided Milestone: tbd
Component: Dijit - Form Version: 1.9.1
Keywords: Cc:
Blocked By: Blocking:

Description

When using a dijit.form.DropDownButton? with Internet Explorer 10 and Dojo v1.9.x, the drop down does not close properly.

I have prepared an example. Steps to reproduce:

  • Use IE10 (10.0.6 / 10.0.9200.16618 64 Bit on Windows 7 in my case)
  • Open the example
  • Click the "hello!" DropDownButton?. The "Save" and "Cut" menu items appear correctly, but the drop down menu itself will close neither if you click elsewhere outside the DropDownButton? nor when pressing the escape key. When clicking one of the menu items, their onClick (alert) is executed and the drop down closes correctly. The only way to close the drop down which still works is clicking the DropDownButton? again.

This behaviour does not happen with previous Dojo versions (i.e. 1.8.x, which you can easily check within the sandbox linked above). The behaviour also does not appear when I forcefully set document-mode via developer-tools in IE to anything below 10, i.e. IE9, IE8, IE7 or IE5.

This behaviour also does not occur in other browsers I've tested (Chrome, Firefox, IE9, IE8).

Change History (2)

comment:1 Changed 6 years ago by void

In case the example linked above does not work (anymore), it is exactly the same as the programmatic DropDownButton example from the reference guide.

comment:2 Changed 6 years ago by bill

Resolution: duplicate
Status: newclosed

Duplicate of #17262.

Note: See TracTickets for help on using tickets.