Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#17297 closed defect (fixed)

RangeSlider: clicking remaining bar yields nonsense values

Reported by: Douglas Hays Owned by: Colin Snover
Priority: undecided Milestone: 1.7.6
Component: DojoX Form Version: 1.9.1
Keywords: Cc: bill
Blocked By: Blocking:

Description

When you click the remaining bar (outside the current handles but on the bar), the relative mouse position is compared to the absolute bar position which yields nonsense values.

Change History (12)

comment:1 Changed 6 years ago by Douglas Hays

Component: GeneralDojoX Form
Milestone: tbd1.10
Owner: set to Douglas Hays
Status: newassigned

comment:2 Changed 6 years ago by doughays-dojo <doughays@…>

Resolution: fixed
Status: assignedclosed

In f21df6fbd6063ca4295d8932d12ffa463a36a365/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:3 Changed 6 years ago by Colin Snover

Resolution: fixed
Status: closedreopened

This needs to be backported.

comment:4 Changed 6 years ago by cjolif

Cc: bill added
Owner: Douglas Hays deleted
Status: reopenedassigned

doughays won't backport this. So csnover and/or wkeese I guess if you want this to be backported you should do it otherwise we should close this.

comment:5 Changed 6 years ago by bill

Resolution: fixed
Status: assignedclosed

I tried 1.9 and 1.8, and clicking the bar seems to work fine to me. So I have no way to test a backport, even if I wanted to do it.

comment:6 Changed 6 years ago by Colin Snover

Resolution: fixed
Status: closedreopened

It’s easy to reproduce in both Firefox and Chrome.

  1. Open dojox/form/tests/test_RangeSlider.html
  2. Click in the white space below the second slider under Vertical slider, or the white space to the right of the second slider under Horizontal slider

Expected: Bottom/right slider moves to the clicked point Actual: Top/left slider moves to the clicked point

comment:7 Changed 6 years ago by bill

Owner: set to Colin Snover
Status: reopenedassigned

I see. I'm not going to backport because the cherry-pick doesn't apply cleanly, since _RangeSliderMixin.js was deleted after the change. Feel free to backport if you like.

comment:8 Changed 6 years ago by Colin Snover <github.com@…>

Resolution: fixed
Status: assignedclosed

In 9ec390c901f7b875ddc34d5efbc06f9223033ad6/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:9 Changed 6 years ago by Colin Snover <github.com@…>

In 1255dbb37dc20187fd43e8f55429cd6cbfc9bf77/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:10 Changed 6 years ago by Colin Snover <github.com@…>

In 6064df945ac928f049af9278f01ffaa7126af5d5/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:11 Changed 6 years ago by Colin Snover

Milestone: 1.101.7.6

comment:12 Changed 6 years ago by Colin Snover

This was not a difficult cherry-pick.

Note: See TracTickets for help on using tickets.