Opened 6 years ago

Closed 6 years ago

#17295 closed defect (fixed)

Changing the dojox/mobile/Switch value does not notify watcher

Reported by: Patrick Ruzand Owned by: Patrick Ruzand
Priority: undecided Milestone: 1.9.2
Component: DojoX Mobile Version: 1.9.1
Keywords: Cc:
Blocked By: Blocking:

Description

a watcher registered as myswitch.watch("value", cb) is not notified when the Switch value changes.

The issue is due to the fact the Switch sets its internal 'value' property directly instead of calling WidgetBase?._set().

Change History (2)

comment:1 Changed 6 years ago by Patrick Ruzand

Milestone: tbd1.9.2
Owner: set to Patrick Ruzand
Status: newassigned

comment:2 Changed 6 years ago by Patrick Ruzand <pruzand@…>

Resolution: fixed
Status: assignedclosed

In 43af4ba56f7b589f2afffb9161e21cc2cad40ad8/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 
Note: See TracTickets for help on using tickets.