Opened 6 years ago

Closed 6 years ago

#17294 closed defect (invalid)

Rendering of chart title is slower after plot rendering

Reported by: pschoepf Owned by: pschoepf
Priority: undecided Milestone: tbd
Component: Charting Version: 1.9.1
Keywords: Cc:
Blocked By: Blocking:

Description

Hi, I am having a chart with some more data points (>2000). Works very well with lines only but when markers come into the game it gets slow, especially on mobile devices like iPad. Playing around a bit with the dojo src I found that the rendering of the chart title (in chart.fullRender) takes some very long time when many markers are in the chart. I moved the code block above the block that renders the plot, which reduces overall rendering time by >50%. No side effects observed, however I am not sure if this is true for all cases.

This is the code after moving the title block:

-> first render title if(this.title){

var forceHtmlLabels = (g.renderer == "canvas") && this.htmlLabels,

labelType = forceHtmlLabels
!has("ie") && !has("opera") && this.htmlLabels ? "html" : "gfx",

tsize = g.normalizedLength(g.splitFontString(this.titleFont).size);

this.chartTitle = common.createText[labelType](

this, this.surface, dim.width/2, this.titlePos=="top" ? tsize + this.margins.t : dim.height - this.margins.b, "middle", this.title, this.titleFont, this.titleFontColor

);

}

--> now render plot func.foldr(this.stack, function(z, plot){ return plot.render(dim, offsets), 0; }, 0);

Change History (3)

comment:1 Changed 6 years ago by cjolif

Would you have a simple test case handy to save me the time of creating one and see if I can reproduce? Thanks.

comment:2 Changed 6 years ago by cjolif

Owner: set to pschoepf
Status: newpending

comment:3 Changed 6 years ago by trac-o-bot

Resolution: invalid
Status: pendingclosed

Because we get so many tickets, we often need to return them to the initial reporter for more information. If that person does not reply within 14 days, the ticket will automatically be closed, and that has happened in this case. If you still are interested in pursuing this issue, feel free to add a comment with the requested information and we will be happy to reopen the ticket if it is still valid. Thanks!

Note: See TracTickets for help on using tickets.