Opened 6 years ago

Closed 6 years ago

#17276 closed enhancement (duplicate)

Inconsistency in event type case.

Reported by: Clement Mathieu Owned by:
Priority: undecided Milestone: tbd
Component: Dijit Version: 1.9.1
Keywords: Cc:
Blocked By: Blocking:

Description

The _WidgetBase.on method accepts an event type name which is case-sensitive whereas the _WidgetBase.emit method does not.

Therefore, if you are using an event type name not in lowercase, the event emitted will not match the event listener.

According to Dom Level 3 event specification working draft http://www.w3.org/TR/DOM-Level-3-Events/ the event type names must be case-sensitive.

Change History (1)

comment:1 Changed 6 years ago by bill

Resolution: duplicate
Status: newclosed

Duplicate of #16859.

Note: See TracTickets for help on using tickets.