Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#17260 closed defect (fixed)

Please update "//@ sourceMappingURL=" to instead be "//# sourceMappingURL="

Reported by: darth Owned by: dylan
Priority: blocker Milestone: 1.9.3
Component: BuildSystem Version: 1.9.0
Keywords: Cc:
Blocked By: Blocking:

Description

Warning being thrown - "@ sourceMappingURL=" source mapping URL declaration is deprecated, "# sourceMappingURL=" declaration should be used instead.

as per http://updates.html5rocks.com/2013/06/sourceMappingURL-and-sourceURL-syntax-changed

In 1.9 Line 71 dojo/util/build/transforms/optimizer/closure.js Line 126 dojo/util/build/optimizeRunner.js

Thanks

Change History (5)

comment:1 Changed 6 years ago by chris2m

In case you do not want to adjust the '@' -> '#', there is another fix described in a related jQuery Ticket 13274: http://webcache.googleusercontent.com/search?q=cache:KnZHSUef8FoJ:bugs.jquery.com/ticket/13274

(also explained in #17118)

/*
//@ sourceMappingURL=undeclaredIdentifier
*/

Please fix this issue as it breaks all dojo code in IE8 on any page that uses

//@cc_on before

(e.g. in third party libraries) before dojo loads. Personally, I would prefer making the inclusion of source maps optional, as I do not want sourceMappingURLs to appear in my minified production code.

Thanks!

Last edited 6 years ago by chris2m (previous) (diff)

comment:2 Changed 6 years ago by bill

#17478 is a duplicate of this ticket.

comment:3 Changed 6 years ago by dylan

Milestone: tbd1.9.3
Priority: undecidedblocker

comment:4 Changed 6 years ago by dylan

Owner: set to dylan
Status: newassigned

https://github.com/dojo/util/pull/15 has the pull request... seems trivial, but needs to be tested.

comment:5 Changed 6 years ago by Colin Snover

Resolution: fixed
Status: assignedclosed

Why are hooks broken again?!

Fixed in fc2a249f99203e94ae03110c49e6eb1486026f3e (master) Fixed in 8ac30717c73a5adc536b0f402d8873d9baf22d70 (1.9)

Last edited 6 years ago by Colin Snover (previous) (diff)
Note: See TracTickets for help on using tickets.