Opened 13 years ago

Closed 12 years ago

#1726 closed defect (fixed)

custom widget namespace camelcase does not work in ie

Reported by: guest Owned by: anonymous
Priority: high Milestone: 0.9
Component: General Version: 0.3
Keywords: Cc:
Blocked By: Blocking:

Description

If you use camelcase to specify a custom widget namespace, such as "customPackage.widget", then IE6/7 will fail to recognize/parse any of the widgets (but they work perfectly in Firefox!)

IE manages to find the custom namespace code (specified using dojo.setModulePrefix) and loads it (if I make an intentional syntax error in the custom widget, IE will pick it up). I think the problem is that somehow IE fails to recognize the dojoType of the widget when parsing the page. The widget is specified using <div dojotype="WidgetName?"> and does not contain the package name.

Change History (3)

comment:1 Changed 13 years ago by bill

OK, we're not sure what you are talking about. Please attach a testcase against 0.4. Note that some of the functions have changed. setModulePrefix() is now called registerModulePath(). Search the test directory or maybe manual.dojotoolkit.org for documentation.

comment:2 Changed 13 years ago by dylan

Milestone: 0.9

comment:3 Changed 12 years ago by dante

Resolution: fixed
Status: newclosed

closing, requiring full classnames in 0.9 makes this irrelevant, doesn't it? registerModulePath has it's own issues.

Note: See TracTickets for help on using tickets.