Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#1725 closed defect (fixed)

SSL in IE6 broken by IFrame line 37

Reported by: guest Owned by: anonymous
Priority: high Milestone:
Component: General Version: 0.4
Keywords: SSL iframe Cc:
Blocked By: Blocking:

Description

Using a menu2 widget in IE6 with SSL prompts (when dropping down the menu) asking if you want to display unsecured content. This is from the iframe created on line 34 of srchtmliframe.js. Adding a src=blank.html attribute fixes the problem, but causes the page to try to load blank.html when the menu drops down. IE7 thankfully has this fixed.

Change History (3)

comment:1 Changed 13 years ago by Dustin Machi

Resolution: fixed
Status: newclosed

(In [6292]) make bgiframe load the richtextframe.html, to avoid ssl errors (and avoid distributing an additional) html file. Fixes #1725

comment:2 Changed 13 years ago by bill

The previous code [6212] had src="javascript:false", and I tested it and it was working fine in IE6 (against https://.../test_Menu2.html). So I'm gonna revert [6292]. If you have a testcase where it doesn't work then please update this bug.

This bug is basically a duplicate of #548, right?

comment:3 Changed 13 years ago by (none)

Milestone: 0.4

Milestone 0.4 deleted

Note: See TracTickets for help on using tickets.