Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#17239 closed defect (fixed)

[regression] dojox.layout.FloatingPane dock doesn't work in dojo1.9.0

Reported by: lachlan Owned by: dante
Priority: low Milestone: 1.9.2
Component: DojoX Layout Version: 1.9.0
Keywords: Cc:
Blocked By: Blocking:

Description

FloatingPane? dock doesn't work any more. The same code works perfectly in dojo1.8.3.

Tried dojo nightly test of test_floatingpane today (7th June, 2013), and it doesn't work either:

http://archive.dojotoolkit.org/nightly/dojotoolkit/dojox/layout/tests/test_FloatingPane.html

When I minimize the five dockable panes they just disappear.

Tried dojo 1.8 test of test_floatingpane, and it works:

http://download.dojotoolkit.org/release-1.8.0b1/dojo-release-1.8.0b1/dojox/layout/tests/test_FloatingPane.html

When I minimize the same five dockable panes they docked at screen right and at the bottom.

First reported by, and report copied from, brightsea's mailing list post (which means it hasn't been working since at least 9th May, 2013):

http://dojo-toolkit.33424.n3.nabble.com/dojox-layout-FloatingPane-dock-doesn-t-work-at-dojo1-9-0-td3996411.html

Change History (7)

comment:1 Changed 7 years ago by bill

Milestone: tbd1.9.1
Owner: set to dylan
Status: newassigned
Summary: dojox.layout.FloatingPane dock doesn't work in dojo1.9.0[regression] dojox.layout.FloatingPane dock doesn't work in dojo1.9.0

FloatingPane? was completely broken in fa393559ad4452b69b2042d8011d32b137366a63 and somewhat repaired after that in bb1f9917ab5cac1bbe1b9e5a2718eeeebf20b9c5, but the docking never worked after the fa393559ad4452b69b2042d8011d32b137366a63 check in.

comment:2 Changed 6 years ago by Colin Snover

Milestone: 1.9.11.9.2

1.9.1 is released; moving all outstanding tickets to next milestone.

comment:3 Changed 6 years ago by raupp

I found the problem:

In file Dock.js on line 18 a mistaken typing

templateString: '<div class="dojoxDock"><ul dojo-dojo-attach-point="containerNode" class="dojoxDockList"></ul></div>',

Solution:

templateString: '<div class="dojoxDock"><ul data-dojo-attach-point="containerNode" class="dojoxDockList"></ul></div>',

comment:4 Changed 6 years ago by bill

From fa39355.

comment:5 Changed 6 years ago by dante

Owner: changed from dylan to dante
Priority: undecidedlow

comment:6 Changed 6 years ago by Bill Keese <bill@…>

Resolution: fixed
Status: assignedclosed

In a231c07700de7f17db62139493313888850f2ab9/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:7 Changed 6 years ago by Bill Keese <bill@…>

In 5975bd2b886b168e7fb64e2813651809ad833ebd/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 
Note: See TracTickets for help on using tickets.