Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#17233 closed defect (fixed)

Problem with dojo transition using dojox app

Reported by: bdouls Owned by:
Priority: undecided Milestone: 1.9.2
Component: DojoX App Version: 1.9.0
Keywords: Cc:
Blocked By: Blocking:

Description

We got a problem using dojox.app with transitions. We have organized the 'view' area of the config.json like this : "views": {

"depannage": {

"view": {

"view1": {

"template": "depannage/view1.html" "controller": "depannage/view1.js"

}

}

}, "shared": {

"view": {

"view2": {

"template": "shared/view2.html", "controller": "shared/view2.js"

}, "view3": {

"template": "shared/view3.html", "controller": "shared/view3.js"

}

}

}

} Here the step by step to reproduce the problem with the example above:

  • click on a ListItem? contained in view1, open view 2.
  • first transition is done without problem.
  • come back in view1 with return button.
  • click again on a listItem to open a view3.
  • the transition is done twice (view 1 to view 2 and view 2 to view 3).

There is scrollbar position problem in the view3 displaying because the fixed top and bottom have no effect after these two transition.

Change History (2)

comment:1 Changed 6 years ago by Ed Chatelain

Resolution: fixed
Status: newclosed

I believe this has been fixed by fix for this issue: https://github.com/dmachi/dojox_application/issues/204

If you still have the problem please reopen this ticket. I am sorry I did not see this when it was opened, for some reason I did not get notified.

Regards, Ed

comment:2 Changed 6 years ago by bill

Milestone: tbd1.9.2
Note: See TracTickets for help on using tickets.