Opened 7 years ago

Closed 6 years ago

#17231 closed defect (duplicate)

Mozilla cannot click around in textbox when in movable dialog

Reported by: brianlschultz Owned by: brianlschultz
Priority: undecided Milestone: tbd
Component: DnD Version: 1.7.3
Keywords: Cc:
Blocked By: Blocking:

Description

When we have a textbox (a plain input type="text" or dojo textbox) on a moveable dialog (dijit/Dialog) we cannot click into the text field that contains data. The cursor just stays at beginning.

When I set draggable to false I am able to move cursor around within the textbox.

Attachments (1)

dojoTest2.html (1.6 KB) - added by brianlschultz 6 years ago.
Example of textbox in Dialog

Download all attachments as: .zip

Change History (8)

comment:1 Changed 7 years ago by brianlschultz

BTW - This only happens in Mozilla FireFox?

comment:2 Changed 7 years ago by bill

Owner: set to brianlschultz
Status: newpending

Works fine for me (mozilla firefox, dojo 1.7, mac). As usual, you'll need to attach a test case using the attach file button, or explain how to reproduce with one of our existing testcases.

Changed 6 years ago by brianlschultz

Attachment: dojoTest2.html added

Example of textbox in Dialog

comment:3 Changed 6 years ago by brianlschultz

Status: pendingnew

Attachment (dojoTest2.html) added by ticket reporter.

comment:4 Changed 6 years ago by brianlschultz

The issue seems to be related to setting draggable to 'true' in the constructor. I know the default is 'true' but we have times where we need to set to 'false'

Please advise.

comment:5 Changed 6 years ago by bill

Haven't debugged your test case yet, but I'm assuming the problem is the evt.preventDefault() call in dnd/Moveable, also discussed in #17222.

comment:6 Changed 6 years ago by brianlschultz

My work-around for now is just don't set draggable to 'true' (default value anyway)

comment:7 Changed 6 years ago by bill

Resolution: duplicate
Status: newclosed

Duplicate of #14452.
Turns out this is already fixed, by me.

Note: See TracTickets for help on using tickets.