Opened 6 years ago

Closed 5 years ago

#17229 closed defect (fixed)

dojox/mobile/Overlay: when used inside a ScrollableView, the Overlay can appear at a wrong location thus being invisible

Reported by: Adrian Vasiliu Owned by: Sebastien Brunot
Priority: undecided Milestone:
Component: DojoX Mobile Version: 1.9.0
Keywords: Cc: Sebastien Brunot
Blocked By: Blocking:

Description (last modified by Adrian Vasiliu)

When a dojox/mobile/Overlay is used inside a dojox/mobile/ScrollableView, showing the opener can make it appear at a wrong location, outside of the visible area.

How to reproduce:

  1. Open https://bugs.dojotoolkit.org/attachment/ticket/13865/test_Opener-scroll.html on Safari (iPhone or iPad)
  2. Scroll the view down to the field and tap it.

==> The opener is displayed above the field, not at the bottom of the screen but at the top of the page thus in an invisible area...

Issue initially reported by Sebastien Brunot in a comment of #13865. Since it is a distinct issue, I create a separate ticket for it.

Change History (12)

comment:1 Changed 6 years ago by Adrian Vasiliu

Cc: Sebastien Brunot added
Component: GeneralDojoX Mobile
Milestone: tbd1.9.1
Owner: set to Adrian Vasiliu
Status: newassigned

comment:2 Changed 6 years ago by Adrian Vasiliu

comment:3 Changed 6 years ago by Adrian Vasiliu

Milestone: 1.9.1future

Postponed to give us time for a saner solution (see the discussion in the PR).

comment:4 Changed 6 years ago by Adrian Vasiliu

The saner solution was brought by... iOS 7, where the controversial part of the PR is no longer necessary.

comment:5 Changed 6 years ago by Adrian Vasiliu

Description: modified (diff)

comment:6 Changed 6 years ago by Adrian Vasiliu

Summary: dojox/mobile/Overlay: when used inside a ScrollableView, the Overlay can cover the field associated to itdojox/mobile/Overlay: when used inside a ScrollableView, the Overlay can appear at a wrong location thus being invisible

comment:7 Changed 6 years ago by Adrian Vasiliu <vasiliu@…>

Resolution: fixed
Status: assignedclosed

In cb8bc433d711a028f22f051c4a0e55d318cbb39a/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:8 Changed 6 years ago by Adrian Vasiliu <vasiliu@…>

In 95795b079c79771d9ab969679ae409c16f3ed429/dojox:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:9 Changed 6 years ago by Adrian Vasiliu

Milestone: future1.9.2

comment:10 Changed 5 years ago by Sebastien Brunot

Milestone: 1.9.2
Resolution: fixed
Status: closedreopened

Reproduced with safari browser on iOS 5 (ipad 1) with dojo 1.10 beta1.

Using the test page dojos/mobile/tests/test_Overlay.html:

  1. Click the popup button at the top: the overlay is correctly displayed
  2. Click the Done button of the overlay: it is correctly hidden
  3. Scroll to the bottom of the page and click the pop up button there: the overlay is not visible
  4. Scroll to the top of the page: the overlay is there, it opened at its first position instead of opening at the bottom of the page

comment:11 Changed 5 years ago by Sebastien Brunot

Owner: changed from Adrian Vasiliu to Sebastien Brunot
Status: reopenedassigned

comment:12 Changed 5 years ago by Patrick Ruzand

Resolution: fixed
Status: assignedclosed

Since it affects an outdated ios version (5, while we are at 7.1 as of today), I don't want to take the rist the fix breaks on another platform. In case someone needs a workaround, a possible fix is available here: https://github.com/dojo/dojox/pull/105

Note: See TracTickets for help on using tickets.