Opened 6 years ago

Closed 5 years ago

#17218 closed defect (fixed)

SwapView: after a quick back and forth swipe gesture, the screen is blank

Reported by: Sebastien Brunot Owned by:
Priority: undecided Milestone: 1.9.2
Component: DojoX Mobile Version: 1.9.0
Keywords: Cc:
Blocked By: Blocking:

Description

This is reproducible using an iPad (iOS5 and 6, not tested on other devices): display the test page dojox/mobile/tests/test_SwapView.html, swap to the second view entitled "Search Result". From there, touch near the right border of the view and do a quick swipe gesture to the left and then to the right (without stopping between the two directions, and go all along to the right border, leaving the touch screen): the first view is briefly displayed and then it disappears and the screen is blank.

Note that you may have to repeat the quick swipe gesture a few times to get it right and reproduce the issue.

After analysis, it appears that after the last transition all views except the first one are hidden, but the first one is off screen because it has a translate3D value that is not 0 on the X axis.

Change History (4)

comment:1 Changed 6 years ago by Adrian Vasiliu

Tried to reproduce on iPad 4 iOS 6 and 7, using both Dojo 1.9.0 and 1.9.1, and couldn't. Did not reproduce on Galaxy S3 Android 4.1.2 either. I might not do the right gestures. More exactly, I only reproduce from time to time situations where the views, after end of transition, are a bit horizontally shifted, but no blank screen.

Last edited 6 years ago by Adrian Vasiliu (previous) (diff)

comment:2 Changed 5 years ago by Patrick Ruzand

Is it still reproducible or not ? If not, please close the ticket.

comment:3 Changed 5 years ago by Sebastien Brunot

I do not reproduce on iPad 2 / iOS 6 using the current master branch. I can get the views into a "strange" state where the current swap view is not centered and there is a small portions of a blank view on its left, but it's not as big a deal and it resolve itself when touching the view once again. I'll check if it's also fixed in 1.9.2 or 1.9.1 to close it whith a proper milestone value.

comment:4 Changed 5 years ago by Sebastien Brunot

Milestone: tbd1.9.2
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.