Opened 7 years ago

Closed 7 years ago

Last modified 5 years ago

#17217 closed defect (fixed)

[regression] Setting new store on Select is not removing old options

Reported by: adros Owned by: Douglas Hays
Priority: undecided Milestone: 1.8.5
Component: Dijit - Form Version: 1.8.4
Keywords: Cc:
Blocked By: Blocking:

Description

When I set new store to dijit/form/Select, old options are not removed (same behaviour on dojox/form/CheckedMultiSelect).

I suppose that this bug appears because of this commit b43a64589.

removeOption: function(/*String|__SelectOption|Number|Array*/ valueOrIdx){
    this.getOptions([].concat(valueOrIdx));

Argument valueOrIdx that is passed to this method is NodeList?. And concating [] with NodeList? will return [NodeList?].

I have attached test case, and also proposed patch.

Attachments (2)

patch.diff (719 bytes) - added by adros 7 years ago.
_formSelectWidgetTest.html (1.8 KB) - added by adros 7 years ago.

Download all attachments as: .zip

Change History (12)

Changed 7 years ago by adros

Attachment: patch.diff added

Changed 7 years ago by adros

Attachment: _formSelectWidgetTest.html added

comment:1 Changed 7 years ago by bill

Milestone: tbd1.9.1
Owner: set to Douglas Hays
Status: newassigned
Summary: Setting new store on Select is not removing old options[regression] Setting new store on Select is not removing old options

Sounds like a regression, in which case it would ideally go into 1.9.1.

comment:2 Changed 7 years ago by Douglas Hays

Milestone: 1.9.11.8.5

Started in 1.8.4.

comment:3 Changed 7 years ago by doughays-dojo <doughays@…>

In 432cd4ec732e10a5e88a5606689464b25f9c05df/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:4 Changed 7 years ago by doughays-dojo <doughays@…>

In 2876164aa20aff71392d37d3d492e30d4618c6b3/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:5 Changed 7 years ago by doughays-dojo <doughays@…>

Resolution: fixed
Status: assignedclosed

In ad391fdd3b3b3879ba7a44046e1c4a272b586164/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:6 in reply to:  5 Changed 7 years ago by bill

Version: 1.9.01.8.4

comment:7 Changed 7 years ago by Douglas Hays

#17107 is a duplicate of this ticket.

comment:8 Changed 5 years ago by Bill Keese <bill@…>

In bd849ff164cd1ac4bb3a5c115042d6837385b663/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:9 Changed 5 years ago by Bill Keese <bill@…>

In d2ec798b42df0292ecc75b60670e06269658830c/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:10 Changed 5 years ago by Bill Keese <bill@…>

In b307063f6d565e374d9185b6dad7f3b5b4f2517f/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 
Note: See TracTickets for help on using tickets.