Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#17207 closed defect (fixed)

[regression] Tree's open on double click no longer works

Reported by: rjh Owned by: liucougar
Priority: undecided Milestone: 1.9.1
Component: Dijit Version: 1.9.0
Keywords: Cc:
Blocked By: Blocking:

Description

It seems like Tree's open on double click is no longer working. In the _onDblClick function, there is a check for openOnClick instead of openOnDblClick.

if(nodeWidget.isExpandable && (this.openOnClick || isExpandoClick)){
    // expando node was clicked, or label of a folder node was clicked; open it
    this._onExpandoClick({node: nodeWidget});
}else{
    this._publish("execute", { item: nodeWidget.item, node: nodeWidget, evt: e });
    this.onDblClick(nodeWidget.item, nodeWidget, e);
    this.focusNode(nodeWidget);
}

Change History (5)

comment:1 Changed 6 years ago by bill

Milestone: tbd1.9.1
Owner: set to liucougar
Status: newassigned
Summary: Tree's open on double click no longer works[regression] Tree's open on double click no longer works

Looks like a regression from 7cb9eef2ebbb72c5bfb339d72e1abb02975990f1 (#16993), Cougar can you fix:

comment:2 Changed 6 years ago by Heng Liu <liucougar@…>

Resolution: fixed
Status: assignedclosed

In b051fc9586224f2ce67c0f37966a0971052df627/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:3 Changed 6 years ago by Bill Keese <bill@…>

In 75cf90f06b81c096c36de1a8a9a42838c53d23ed/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:4 Changed 6 years ago by Bill Keese <bill@…>

In af7db126555b5c6179f00e2bcac7b271c0fde215/dijit:

Error: Processor CommitTicketReference failed
Unsupported version control system "git": Can't find an appropriate component, maybe the corresponding plugin was not enabled? 

comment:5 Changed 6 years ago by bill

It didn't show up here, but I backported the fix to 1.9 in 9dcc6d79dbc9f774fa8a1fdbc3acab894c3d8306.

Note: See TracTickets for help on using tickets.